Blizzard Update Agent incessant UAC prompts

Since Blizzard changed the forums, any links to old posts about this issue don’t work anymore, which is extremely dumb.

But since those posts were dating back to 2017, I’d like to know if there was ever a resolution or some kind of workaround (without changing my UAC settings).

For anyone not in the know: The “Blizzard Update Agent” aka agent.exe keeps incessantly popping up every few minutes, taking focus away from any game I’m playing. The only fixes I was able to find was to set the setting “exit the app on game launch” and to change my UAC settings both of which are not ideal, as I am playing other games not on Blizzard and I do not want to compromise my security.

If anyone has found any other (more viable) solutions, I would greatly appreciate it. Thanks in advance.

Hey, marcus82! Those were the common workarounds we’ve seen when the UAC is set too high. Usually setting this a bit lower helped reduce the prompts. Which isn’t ideal, but there have been a few other workarounds we’ve found, that’s helped a others in the past.

  1. Troubleshoot the security software. It could be that the trusted applications may be causing restrictions with the Blizzard Application. If this helps, try adding an inclusion/exception for the application. Please refer to the software developers if assistance is needed.
  2. Let’s try a reinstall and check on the secondary logon settings.
    1. Uninstall the Blizzard Application
    2. Delete the Cache and Tools folders
    3. Enable the Secondary Logon.
    4. Reinstall the Blizzard Application.
  3. Run through a system file checker and a ScanDisk scan.
1 Like

Thank you Caterpepi. The UAC prompts are completely gone. I reinstalled the Blizzard app as per the instructions and enabled Secondary Logon, it was set to Manual. I also did sfc and dism, but I suspect the issue was the Secondary Logon service since this is a very new Windows installation (about a couple weeks old). Thanks again.

PS: In case you were wondering, I’m just using Windows Defender as my security software atm.

1 Like

Hi there, sorry to revive an old thread but I have a similar issue and folllowing the steps above have not fixed it. I uninstalled, enabled the secondary account, deleted the folders, restarted windows and reinstalled without luck. I tried it a second time without luck either. I have the blizzard app set to start automatically on my new clean installation of windows 11 and on every boot, I get a UAC prompt for the blizzard updater. I do not have this issue on my previous windows 10 installation, which was also a clean install. I would be grateful for some advice.

1 Like

Below is the text from the UAC prompt:

Verified publisher: Blizzard Entertainment, Inc.
File origin: Hard drive on this computer
Program location: “C:ProgramData\\Agent
Show information about the publisher’s certificate
Change when these notifications appear

1 Like

Hey, do have the answer? I got the same problem…

1 Like

No, I still haven’t fixed it. When did you start getting the problem? Are you also on windows 11 and if so did you do a clean installation or upgrade?

No, i did a clean win10 installation. right after that the uac appears again and again

Cool thanks for getting back to me. I thought maybe it was to do with the secondary log but I’ve reinstalled the app about 5 times since enabling that. I only get the prompt when windows starts, it sounds like you are getting it more often than that? The last thing I’m thinking of is creating a new local administrator account and installing it with that. I logged in with my Microsoft account, it says it’s an administrator account but worth a try to create a new one. Did you log in with a Microsoft account during the installation?

I geet it, everytime i want to launch the battle net launcher. and yes, i logged in with my microsoft account during the installation. i dont know whats wrong… maybe its just a battle net agent thing. and we have to wait for an update… dont know… :frowning:

1 Like

Yea it’s very annoying. I wonder if it’s something to do with the Microsoft account but then that’s how I installed windows 10 last time. Shame no one else is having the issue and we have had no contact from blizzard support…

Getting the same after updating to windows 11. Have tried the steps linked in the “answer” but no luck. Please look at this Blizzard.

Same here with Windows 11. Please check.

Just did a clean install of Windows 11 and I am getting this everytime I boot up windows.

1 Like

I think i fixed it. But i dont know how. I started the agent today over the windows start menu…
And the UAC did not appear. In the settings of the agent i enabled the “startup at windows”-function and it works!!

What do you mean by started the agent? Do you mean the update agent.exe or the blizzard app itself?

I am still getting the uac prompt. It only occurs when launching for the first time.

1 Like

I have done the top comments instruction 3 times over, why is it still happening? kinda tilted as I wasted hours on this when everything should work out of the box

i mean just the program in the start menu. dont know where the difference is… i dont understand why it works now… when i start the .exe the uac appears. when i start the agent from the start menu it doesnt show up

That’s interesting, thanks for getting back to me, I’ll try that… can you get it to open minimised that way? At the moment I use a task which opens it with admin privialges without the prompt but I haven’t figured a way to get it to open minimised. My brother upgraded (I did a clean instal) and he doesn’t get the prompt…