Blizzard Error on app launch

Whenever I try to launch Battle-net it attempts to log me in then it crashes. Here is the Report ID 97DA91B1-B8B4-41A2-AAD3-8512BBA7A685

Hey there,

It looks like the gpu drivers aren’t working well with the app. I’ve seen this a few times recently. So far the fix in every case is to install an older version of the graphics drivers.

Do you know what graphics card you have?

If you’re not sure, go ahead and grab a DxDiag so we can further investigate the problem. Here are the instructions:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post, and put four Tilde (~) marks above the DXDiag. It’ll look like this:
DXDiag goes here

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

pastebin (dot) com/yECY1AC2

Hey there,

Lets use this DDU software to remove the current set of drivers (this will restart the PC.) After the PC finishes restarting, try installing the 19.11.3 drivers listed on this page.

Let us know if this works for you!

It didn’t, I already tried that. I have also updated to the newest one as well. I also attempted to reinstall battle net and it gave a similar error.
Clearing the appdata and localappdata folders helped, but after a few minutes it crashes again.

Seriously? Install old drivers? Other games need the newest. Man I wish Overwatch worked on OSX where I never have driver problems.