Battle.Net stuck Installing at 1%

I have tried everything and anything to get this damn installer to work, but I keep getting stuck at 1% and it won’t go up… I don’t understand why Blizzard hasn’t fix this issue. I have since cancelled my subscription because I cannot play WoW. I’m hoping with Microsoft taking over things get done around here with their garbage Battle.Net app.

4 Likes

I have exactly the same problem… it says “Downloading new files…”, the loading is done until the “w” of download (“l” of Telechargement in french) and after, I can wait 1h, 5h even several days, nothing happens… it stays stuck there…

How to do ?..

I am having the same issue. Been trying for months now. I give up.

1 Like

Yes I have been trying for months, its absolutely ridiculous that Blizzard cannot fix their App

1 Like

Hey there,

If the applications stalls while attempting to download/install data for itself or a specific game client then it typically means either corruption with the desktop application or interference/restrictions on the system or network.

The following steps should help rule out the more common causes of something like this:

Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 30 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

Sometimes firewall or routing software/hardware will have some advanced settings to prioritize and manage types of network traffic. Normally that is not an issue but we have seen situations where it can intefere with the delivery of the data for our games/voice chat.

Let’s try turning off these features:

QoS
SIP ALG
RoG (ASUS Routers Only)
Security firewalls (Some ISP provided modems)

Not all devices will have these options and the steps for turning these functions off will be different depending on the make/model/software version of the devices and programs involved. If necessary look at the documentation for your security and routing products to find out how to turn these options off.

In some cases there is a corrupt or misconfigured setting within the router or modem. We cannot say what that might be offhand but the easiest way to resolve these conflicts would be to factory reset the router and/or modem.

You may need to look up your specific model for the steps on how to do this and in some rare cases you may need to have this done by the ISP. Feel free to reach out to them for assistance if necessary.

From here we need to manually clear the Battlenet Desktop Application and all supporting data from the system. This will not remove existing game clients.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.

Try running your system in selective startup mode: https://battle.net/support/article/200483

Create a new administrator account: Creating a New Administrator Account - Blizzard Support

Once the account is created, shut down the computer, wait 60 seconds, restart, log into the new profile and try the app/client.

If that does not help we recommend submitting a ticket for more direct support: Contact Support - Blizzard Support

Be sure to include the requested diagnostic data with your ticket. I also recommend attaching connection data using the steps in this article:

These guys appear to be newbies, How can I be of assistance? I’m primarily a Linux user, but have worked in the IT support field for over 10 years.

Please do not give up! Have you checked your windows log files?

What is your problem, young jedi?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.