BattleNet Security Certificate Issue - Mac

When I open the app, I get error BLZBNTBNA00000640. I have tried all of the solutions on the page, as well as completely deleting all files from the computer, in every folder where any preferences or cache could be stored. It keeps telling me it can’t log in. If I try and run WoW directly, I get a disconnection error BLZ51914400 as I try and log in. This is going on two days now. Nothing has changed with my OS. I was able to play on Monday just fine. I tried running the Trace Route for more info, but the txt file was blank with both Americas IP addresses. Likely because I can’t actually connect to them. I even went into my system certificates and checked to make sure everything is still valid and trusted, and everything seems fine. I’m running Ventura and have no outstanding security updates.

I have been scouring the internet and the Blizzard forums since this started last night. I have tried everything at least twice. There was a WoW update yesterday and suddenly this BattleNet issue started, so I suspect they are related somehow. I’ve put in a ticket, but I’ve just been told to do all the things I already did.

Things I’ve tried:
Deleting every single BattleNet file (even hidden preferences) and reinstalling.
Doing that with a new admin log in
Hard-wiring the internet
rebooting the router
connecting via a different internet connection
flushing DNS and renewing my IP
turning the firewall off
whitelisting Battlenet and WoW in the firewall
manually checking security certificates
deleting the Battlenet certificate and forcing it to create a new one
running an anti-virus scan (I used Bitdefender and Malware Bytes)
deleting WoW cache files (just in case this was affecting it somehow)

I feel like I’m actually forgetting some of the other things I’ve tried because I’ve done so many. Anyone have any other suggestions?

This is the PC tech support forum. You want this one:

Desktop App Mac Tech Support

1 Like

Thanks. Super weird, I swear it was under the Mac Tech Support heading when I posted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.