Battlenet patch 14542 not working in wine

While I realize Linux/wine are not officially supported, the above launcher does not start. There had been no issues prior to this latest update.
I have even reinstalled the launcher in case there was patching issue. No luck. No error messages were given. The login screen and launcher just never show up.


def the update. I reached out to CodeWeavers and here is their reply:


Thank you for reaching out. We have replicated this failure after the client was updated, and are looking into solutions. We don’t have any immediate suggestions, but will attach your ticket to our bug report so we can notify you if we find a fix. We appreciate your patience, and apologies for the inconvenience.

CodeWeavers Support

1 Like

Thank you. Please post here is they say something more.
So much for Season of Discovery…

Close Lutris > go on your drive > drive_c/Program Files (x86)/ > delete folder > bnet will fallback to old version

this should work.


Thank you! It’s not clear how many times I will have to learn this, but I know it’s at least five at this point.

Not using Lutris, but Crossover for Mac. This does not work for me - getting a DLL error.

1 Like

its for op, dunno why ppl use mac or win. but this is another problem

1 Like

If only I didn’t remove the battlenet completely to do a fresh install… ./facepalm

if you have a friend or trusted person you can take his folder, works to. in lutris discord is another link for download version before update

I’m getting a gray screen it logs in but won’t go threw to battle net. I tried everything I play on a steam deck running steamos Linux

OMG this worked - joined the discord and DL the old version. Thank you!

GG :smiley: have fun dude v:

same same…cant even play now thanks blizzard…if u could only release your games ON STEAM STORE ALRDY LIKE U DID FOR D4 and OW…

1 Like

I have tried removing current patch directory with no success.
I should say that you may be able to still play the games, at least until they require a patch, by launching them directly. It works for me at least with WoW classic and retail.

This. I have no desire to play anything else on bnet and would love to be able to get rid of the waste of system resources, plus eliminate another company with credit card data I have to worry about getting hacked. Just put WoW on Steam already.

1 Like

How can I start Warcraft without using steam OS Linux? Using protons and steam currently to start

wine “C:\Program Files (x86)\World of Warcraft_classic_\WowClassic.exe”

Adding WINE_SIMULATE_WRITECOPY=1 as an environment variable fixes 14542.


This worked for me on Steam OS as well. I thought it was just lagging out because of the mass flooding of people but yeah deleting this folder finally loaded the blizzard launcher.

/home/deck/.local/share/Steam/steamapps/compatdata/3470563592/pfx/drive_c/Program Files (x86)/

1 Like

That did it! Thanks a lot.

For anyone using Lutris, you just need to add the flag on Configure > System Options > [Scrolldown to “Game Execution”] > Environment Variables.