Battlenet Not Downloading - Solved

I’m unable to download the Battlenet app.

It was previously working on my laptop (windows 10) but today I could not connect to Battlenet so I tried reinstalling.

I have uninstalled and done all the troubleshooting steps in the various support articles. It’s stuck at “Downloading new files” and this error is in the log:
2019-11-09 21:12:18.744978 [Main] {2e78} Downloader - {2e78} WRN (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 2080): HTTP: connection timeout for ‘’ E 2019-11-09 21:12:18.745106 [Main] {2e78} Downloader - {2e78}

ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 392): HTTP: connection failed for host NET_CANCELED

Update: Issue solved

Router’s firewall was updated and settings changed to the maximum

Changed it back to default and BNET app installed


Great job pal! Two weeks and every article lead nowhere. You solved my problem in an instant! Next time you’re in central New York drinks are on me! Thank you so much!

super thanks dude! stupid edge update and changed my firewall setting!

How did you update the router’ firewall. Mine is not working