mobile app authenticator not working

So many problems logging in to so many places. If you’re gonna make everyone switch from the mobile authenticator that WORKS, you should make sure the new one actually works first. Yesterday I had problems with Diablo IV crashing, so I tried to log on to post in the bug report forum. The mobile app authenticator was unable to load login requests and entering the code manually didn’t work two different ways. First time I tried logging in on my usual browser (Firefox), when I pressed the option to enter the code manually on the website, it just brought me back to where I enter my email and password. Then I tried logging in on Chrome, and several times tried to enter the manual code given to me by the mobile app, and it said it was wrong every time. So I removed the authenticator. (Extremely annoying to see the green plus sign to get more bag space in WotLK Classic by connecting the “free and “”“EaSy To UsE””" authenticator" every time I open my damn bags.) So I tried to log on to the bug report forums for the app (on Firefox) to report how DIFFICULT/impossible the authenticator is to use. And every time I clicked “login” so I can make a post, it said “oops, there’s nothing here” once I’m logged in, but every time I navigate back to the forum, I am no longer logged in. So, it’s also impossible to post on the forums using Firefox. Had to switch to Chrome again to make this post.

1 Like

I Have the exact same problem, tried every option Gms gave me and none of them solved the issue, i cant use my old authenticator since I made the migration, on the bnet mobile app i cant use my old serial or code to reactivate the authenticator, every time I reinstall it gives me new serial number.

I’m having the same problem. Is it maybe a t mobile or optimum mobile issue?