Hi! I’ve been playing Blizz games for years on Mac but I’ve only stumbled this problem just now. Cant seem to update my games in app, it just says waiting for another update. I tried uninstalling the app and still doesnt work. Instead, I get stuck at “Updating Update agent…” for hours now. Couldnt find other fix online other than reinstall. Hoping for your fast and positive response.
I’m using Mac Air M1 BigSur

1 Like

I have the exact same problem, I uninstalled the battlenet launcher and now I can’t redownload it. I’m using MacBook Pro.

Dustin Calhoun Thanks to @Dl_techgram on ig who help me unblock his a genius I can strongly recommend him

Anyone have a solution to failing to load on Mac OS 10.13.6?
Tried installing Starcraft for my kids to play but Battlenet won’t open. Updated and installed OK and Icon appears on task-bar on opening app but then no window, no link to Very frustrating! Any help welcome…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.