Battle.net installation stuck at 1%

The other day I tried to update Overwatch as I had not done so in a while but my game would not update at all. So I decided to uninstall Battle.net and reinstall it to see if that would work. Well at this point in time I can’t seem to get the installation screen past 1% no matter what I do. I feel like I’ve tried everything to fix this but for some reason it will not download. I need some help.

1 Like

Same problem. I’m trying to install battlenet app, but it keeps getting stuck “downloading files” at the same point each time. I can leave it running for hours with no improvement, or any sign of activity at all.
I finally decide that enough improvement has been made in working conditions at Blizzard to go back to WoW and Diablo, but I’ve been hit with this bug. Tried; cycling router, cycling broadband connector, clearing out any and all files with blizzard or battle.net, creating a new admin account, specially giving permission to my bog-standard windows 10 firewall, briefly switching off my anti-virus (bog standard windows defender again), turning windows firewall off. None of this worked.
I have no trouble downloading games from Steam or Origin, so I really don’t think the problem is at my end.

Ah, well. At least I can download Final Fantasy sucessfully.

1 Like

i got more help from the support and this worked
• Try rebooting with Selective Startup:
This can be used to close out background processes and non-Microsoft services that could be interfering with the connection or the game client.

  • Press Windows Key+R.
  • Type msconfig and press Enter.
  • Select Selective startup and uncheck Load startup items.
  • Select the Services tab.
  • Check Hide all Microsoft services.
    Note: Skipping this step may prevent your computer from rebooting correctly.
  • Click Disable all.
  • Click Apply then click OK.
  • Click Restart.
    THIS WORKED

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.