games won't launch

All games will not launch successfully. Some games seem to behave differently when attempting to launch. StarCraft, StarCraft 2, Warcraft 3, and Overwatch will show “Playing Now” in launcher after clicking Play button, and the exe process shows in Task Manager, but the game window never appears. With WoW Retail and Classic, the Play button will remain on “Play”, the process shows in Task Manager, but the game freezes when the game window launches, only shows a black screen and then crashes.

Other games in other launchers (Steam, Epic, EA, Jagex) run without any issues. I first noticed the issue after a recent launcher update, but I’m not certain that is the cause of the issue. I’ve also purchased a new laptop recently and am experiencing the same issues on that one, but no issues on my desktop.

I’ve found that reinstalling Windows will temporarily fix the issue, but after installing all OS updates, software, etc., and after rebooting a few times, the games will stop launching again.

Have been playing games on this laptop for over a year with no issues until about 2 weeks ago.

Laptop specs:

Model - Surface Laptop Studio
OS - Windows 11 v. 10.0.22631.3155
CPU - 11th Gen Intel i7-11370H
GPU - NVIDIA GeForce RTX 3050 Ti Laptop GPU

Using Sophos for Anti-Virus and device encryption

That app has been blocking since the patch and update. Reach out to Sophos for updates if you don’t want to disable it.

1 Like

Thank you. I will do a Windows reinstall on my old laptop, and not install Sophos to verify your claim. I’ll follow up with my findings in a day or so.

it wont even let me uninstall sc2… i keep getting an error… and telling me to conact you guys

same issue but i run webroot for antivirus win 11 intel i9 geforce rtx 4080

wont even let me unistall battle net and ive never had any issuses

I only use the generic windows defender – ive uninstalled and reinstalled and call of duty 4 times each, fresh downloads each time - deleting every single file from my computer first to make sure its all fresh… diablo 4 and 2 load fine… call of duty used to at least show the splash screen but after the first attempt after every reinstall it doesnt show at all… the “play” button just darkens and says playing, then pops back to “play”… no reply from activision or ticket…


Same here:( Sophos not letting me launch SC2 since a week

so for me I’m trying to launch warzone using GeForce and i get the message: the game quit unexpectedly. try playing it again. and that happens after I press lets go and a little after I finish typing my password but If I don’t press lets go I get the message: you need to restart the application to finish a required update. this will pause any in progress game updates or installations. slightly covered up by the lets go button.

Any update @Triatt-1714 ?

I am having the same issue, the Battle net Launcher doesn’t even start. Stays in the background and I can only “kill” it with the task manager and close task.

I’ve tried multple fixes suggested online:

  • Method 1. [Run Launcher as Administrator]
  • Method 2. [Reset TCP/IP Settings and Flush DNS Cache]
  • Method 3. [Disable Proxy Server]
  • Method 4. [Delete the Tools and Cache Folders]
  • Method 5. [Enable the Secondary Logon Service]

and it still doesnt work, this is really frustrating.

I’ve uninstalled Battle net launcher and installed again and the same issue occurs…

Tried to launch World of Warcraft game directly but when it logs in all Realm servers say “incompatiple” do I cant even play the game directly.

Blizzard should pay some compensation to people for this.

I have a problem with battlenet , and this is if I go by pressing the word play, it does not enter me to a game. I want to solve the problem. Please, and I have an illustration of the problem. Thank you.

Still have issues, reported and I havent got any reply.

Bumping this topic…

My partner and I just tried to log into SCII, and we’re both having the same issue. Game automatically updated, now it won’t launch.