blocking graphics card

When I use the battle net launcher, it says it won’t switch to Nvidia graphics card. It says the program blocking it is Its forcing my computer to use the integrated graphics card which is horrible and unplayable. Ive uninstalled and reinstalled app several times. Then randomly, about 1 out of 15 attempts, it swaps to the correct graphics card. HELP


Same here, it has got to do with the new update on battle net.

Yep, same here. Come on, Blizzard, can you test your apps properly?

Just came across this problem myself. kept lagging and stuttering in game and thought new laptop was playing up already.

Theres been a few posts on this with no response from Blizz so far. Any movement chaps?

solution is, close the battle net as soon as you open the game.

I’m having this issue after update as well.
My temporary solution was to make a short cut of wow.exe straight from the file directory. Still annoying though, and would be nice to see it fixed sooner rather than later.

Hey everyone,

I have reported this up for investigation and we would like to see the exact error you are getting when attempting to launch. If you could screenshot the error and reply back with it, that would be helpful.

1 Like

for now just enable the manage display mode in the desktop tab in the nvidia control pannel. that way you can switch manually to the nvidia GPU withought opening up the nvidia contro center everytime. ull have a little tab pop up when you click the icon in the taskbar and you can switch between automatic/optimus/nvidia gpu.

why dont you just manually select nvidia gpu before you launch the game through the manage display mode tab. its just one click that way you dont have to be closing apps

I get the same thing optimus cannot swap to discrete graphics card when I start the game. When I click on more information it displays a list of 5 processes that are blocking it. Will try to create it again here shortly and post screenshots of the popup window. Right now I manually swap it before booting the game. Hopefully it gets fixed soon though as not a fan of forgetting to swap it, having it yell at me when I boot the game, wait for it to load and then kill the game. Swap the graphics card manually and reboot the game.

Here is the image, doesn’t contain a lot of detail though.

Well, I would post a link if I could, but it won’t let me.

The swap of auto switch worked last week, so it was something recently that started blocking it.

Embedding the screenshot for you:

1 Like

same issue here. i just close battlenet before the game starts up, its annoying but the only fix ive seen

Thanks, I tried imbedding it but it wouldn’t work for me. Glad you got it to work. Don’t post on the forums much, so not sure of all of the tricks.

1 Like

Also receiving this error. Nvidia container pops up and says is not allowing the graphics swap when entering the game. I tried closing quickly while logging into the game and it just shows 4 processes popping up within end task while isn’t even running. Manually swapping for the moment, annoying though.

I am having the same issue here! I hope it gets fixed ASAP.

Same error for me. I can’t post links or images here, but it’s the same error as in the screenshot posted below by Boubou. The only difference is mine is 4 instances of instead of 6.

Same here while launching Diablo 4.

I have the same issue as well. Need to start game with wow.exe , no more for me.

I have the same issue. Hope it gets fixed ASAP :sob: