Battle.net app not working, missing DLL after update

it was working fine until one hour ago, I upgraded battle.net, and now it just wont start because of a missing DLL , i wish i could start overwatch without launching the battle.net app.

4 Likes

same here. tried all the various fixes - scan and repair, reinstall, restore … nothing works

3 Likes

Same thing happened to me after the launcher update and I’m on Windows 7.

I can launch Overwatch and WoW from it’s program directly and it runs after giving my credentials and login information. Though if those two games get updated, then they wont work unless the launcher can work and can update those games.

3 Likes

I’m having the same problem with DLL on windows 11

1 Like

I also encountered a lack of DLL and couldn’t start the client. Is there a solution?

2 Likes

same here.
10 hours ago was working fine. Now bnet keeps giving :
“dll missing download and reinstall” error.
Did multiple uninstall/restart/reinstall …same error .

4 Likes

Same for me, battle.net launcher was fine a few hours ago then stopped working. Tried every combination of reinstall solutions updated all drivers and it still throws “A required DLL could not be found. Please download and reinstall Battle.net.”…

Please let us know whats happening devs :slight_smile:

4 Likes

I hope more people will give feedback to the customer service about this problem. I hope the developers can fix this bug as soon as possible

4 Likes

Mine also doesn’t work DLL not found on windows 7

3 Likes

i am having same exact problem on win7. i have tried everything in the forums. i even reinstalled sc2 and reinstalled win7 all over again on same and different partitions. nothing working!

2 Likes

Battle.net.13434 is the BAD version that doesn’t work:

Battle.net.13369 - WORKS
Battle.net.13401 - WORKS
Battle.net.13434 - DLL MISSING

I did manage to recover battle.net folder from a backup and i have to replace the backup folder every time i restart the computer or when the battle.net app decides to upgrade by itself.

This is why people get frustrated and migrate to other games

5 Likes

same ‘dll missing’ problem here after update, windows 7

how to replace #13434 with another one?

same problem. need someone from customer service to fix

nothing yet. Issue still there ! Any Updates ?

I have this same problem, and have tried all solutions listed in the official site. No luck. Why did this happen?

man No one know how to fix this problem???battle net tech cant even help at all :rage:

in some other thread/post found these solutions,

A> for win 7 x64 users :

https://www.microsoft.com/en-us/download/details.aspx?id=45633

B> 32-bit Windows 7 :
https://www.microsoft.com/en-us/download/details.aspx?id=45588

C> If you want “Battle.net.13401” (working folder), somebody on EU forum provided a link:
https://www.mediafire.com/file/2op97srx95eut4a/Battle.net.13401.zip/file

thanx to all the ppl that provided their insights and solutions

p.s :
solution A seems to be working for me atm
i have not checked B and C

THere are problem with certificates. File agent.exe is signed with
DigiCert Trusted Root G4. Try to download and install it from digicert.

2 Likes

Battle.net. 13521 also doesn’t work