Battlenet app doesn't work android

Since the launch of the newest authorizion app from battlenet i’m unable to login.
I have tried everything I have cleared every caches and data from the app aswell from my google chrome on my phone I have restarted my phone i have reinstalled the whole app nothing works I am staying in an login loop

Mobile that i use is: Samsung galaxy S23
Android version is 13
and One Ui version is 5.1

Same here. On an iphone. My old authenticator stopped working, codes stopped being valid. Authenticator requests wouldn’t give me the option to approve them even though I’d get the pop up notification on my phone, as my account is still attached to my current phone number. Only thing I can do is wait and see if it fixes itself. I’ve tried a ton of stuff so far. The new bnet mobile app will simply not let me log in. I put in my information, it sits there loading for a minute and then finally says “Oops something went wrong”.

Whatever glitch there is in the system is compromising my account security and it’s pissing me off, frankly. Even my security and restore codes, which I have a screen capture of, don’t work and it says they’re invalid. Funny thing is, and I just noticed it… it gave me an EU based serial code, but this is a US based account and always has been. Somewhere along the way, something got screwed up internally on my account but the authentication always worked UNTIL they decided to make the old authenticator app obsolete and force people to use the new bnet mobile app.

Only option I have left now is getting on the phone with Blizzard and seeing if they can fix it on their end. Shouldn’t have to, but it is what it is.

well i know one thing for sure is if they don’t fix this really quickly then i can’t guaranteed the safed of my account and if my account get hacked in the main time battlenet can refund all of my games and ingame items that i have purchased

Does anyone know why they plan on completely shutting off the one that works in favor for one that does not work? I mean besides it being blizzard, whats the logic there?

"We’re no longer supporting this working authenticator, instead you are forced to use one that you cannot use, but must. "