Battle net windows app wont load

it updated today, was working fine. Now it says cannot find DLL file or something and crashes back to desktop. I uninstalled it, reinstalled and it worked. But it made me relaunch it for an update. Which did the same thing.


I’m getting this same error, relaunched to start update and now it can’t find DLL when I reinstalled I noticed after a while it’s telling me an update is available and I’m worried it will give me the same error and I’ll have to repeat the process.

Same problem here, i just opened WoW from the folder and its working so i havent bothered reinstalling


Same. At least reinstall fixes it temporarily.

Same problem here. Had to uninstall and reinstall twice since the reset from Tuesday morning.

Just wanted to chime in, also started receiving this error. Re-install is only a temporary fix. I am on Windows 10, up to date with patches.

Same here. Did the reinstall yesterday but then today, its saying to reinstall again. Win 11 here.

Same problem here since Tuesday
Windows 10, reinstall temporarily fixes

Blizzard is aware and looking into it…

1 Like

I can’t reinstall the app whatsoever. It stated the below message.

“We’re having trouble starting Please try again. If the problem persists, please restart your computer.”

I’m now unable to play. :frowning:


DONT curse Blizzard by saying “Battle Net”. Gawd! The Gremlins plaguing Kixeye will come here!!

same here it was working fine until the update, i have reinstalled the app several times and its just not working, missing DLL, i wish i could skip the app and launch overwatch without it

1 Like

I can manage to launch Overwatch without the App, though you have to input your credentials when prompted.

I’m having issues launching the since the update early today that’s giving me errors that it cant find the DLL it needs.

same here, cant load battlenet launcher because of a missing dll, reinstalling doesnt fix the issue.

A required DLL could not be found. Please download and re-install Battle net.
Thats what I get when I try to start Battle net.
Began this morning.
Edit: I can manage to launch WoW without the App, though you have to input your credentials when prompted.

Haven’t been able to log in at all for a couple days because of this and I just paid for 6 months of game time literally the day or two before. Obviously I am super frustrated. Please fix.

1 Like