Authenticator removal


This is my brothers account. I am unable to log in my own account because of the authenticator. The phone that i have it installed is dead. Screen died and i didnt move it prior to another device. So no access to it. And i neglected notifying earlier at customer support if that is even an option.
A bit over a month ago i had to do a format and when i tried logging in i was asked to verify via authenticator which i have no access to.
So i tried removing authenticator with contacting customer support.
I was contacted on the 27th of april with an email asking for information to verify my identity. I replied on the same email, since there was no link to a form or something, on the 28th. Case id EU94308402.
I never got a reply back. I started wondering if just replying to the email i received with the info that was required was the correct way but the email doesnt say anything different.
So i made another ticket asking why it takes so long for a reply. The contact person completely disregarded the text and chose to possibly start over the process? He again sent me an email asking for information to prove my id albeit a few of the questions where different. I only asked why does it take almost a month to have this thing resolved. I have been paying for nothing. I have been a customer of blizzard for 15 years or so and now im losing cata and pandaria because customer service is at this state…Case id for the second one is EU94500070.

This is ridiculous…And honestly i dont blame the people of customer service/support. But when the execs fire most of the stuff this is what you get. As i said ive been playing blizzard games since forever and ive been honestly thinking of quiting (despite being excited for cata) just because of stuff like this. You have ZERO respect for the customer.

As of 31st of May still no reply. Nothing. I am paying subscritpion for nothing. I cant level. I am lagging behind all my guild. Cant even play any of the other games i own from blizzard. Is there actually any customer service personel left or what??? When calling on the phone was available this was resolved within 10 minutes max…and now its over a month with this ridiculous issue.