Authenticator App linked to BattleNet App = bad idea

Why does the Authenticator go in circles? Log in anywhere says go to authenticator, then the Battlenet App says go to Authenticator which yes, is why I am here. On my phone there is a little back arrow in the corner which say Authenticator and it loops around a few times to get to the Approve button.

WHY can this not just be straight forward and have the Authenticator App? Maybe just keep the Authenticator App or at least make the BattleNet app smart enough to pop up the Authenticator if you ask for it elsewhere.
STILL no word from Blizzard? No fix to this?


I have been playing since 2008 had no problems with the old Authenticator. I can’t do 4M+ because it is requiring me to use the new Authenticator, should say forced requirement, no options. The last time i tried it was asking for a serial number for some device??? sounds like hardware device. Meanwhile i am stuck and grumpy about this non ending loop.

1 Like

I just had to use the mobile authenticator. It sent me to the new app which asked for the authenticator code which I could not provide since the old app doesn’t work. I had to remove the authenticator from my account and then put it back on.
This was a very poor design as far as converting from one authenticator to another. It could have been much better. The process took me over 15 minutes to complete partially due to lack of good information on the new app.

1 Like

I noticed this months ago. Blizzard still has not fixed this. Actual clear incompetence

1 Like

It’s December 5th in 2023 and people are still having issues with this. I’m over it. Sent in a ticket. But if they don’t get back to me, I’m done with blizzard tbh.

I just got a email saying they are disabling the old authenticator app but I can’t get the app to work. All I get is “loading request…” then “opps something went wrong”. How do i transfer to the new app when it doesn’t work? If anyone has suggestions that would be great.