App is re-downloading 300mb~ Beta client file

TL;DR I’m done with until there is a solution, if I was on metered connection it could of spent all the monthly bandwidth and I have no way to stop the download. If there is a way to play Sc2 without client I’d love to hear it for the meanwhile.

I noticed that I am having insane lag and even disconnections during my Starcraft2 games and wondered why. When I started looking for the source of this issue, I discovered that if I go to Settings > Beta I can see a download going from 0% to 100% every single time I start the app and it is actually downloading an 300mb~ beta client - because when the download is done a new button appears which says “Switch to Beta” (yes I’ve even tried switching, the so called “update loop” continues to happen.

While the app is running it also re-downloads the 300mb~ beta client every 30 min - it’s driving me insane and it really eats up all of our traffic. We use 4G and the connection is not good, but when the 300mb~ beta client download begins I sometimes get disconnected too. The worst part is that there is no way for me to pause or cancel this download, and it even happens during my online games which makes it laggy for everyone in that game with me.

  1. Every time I launch, an around 300mb~ “Beta client” file is being downloaded.

  2. When app is running, around every 30 minutes it re-downloads the 300mb~ beta client file.

  3. When the download if finished, I get an green “update” symbol on top left corner (suggesting me that I should update my client now), however when I press it and choose “Restart and Update” from the drop-down menu. It closes the client, and doesn’t update anything so I just have to start it again.

Things I tried (2 days ago):

  1. Completely removing folder and re-installing.
  2. Tried to “update” inside the client, it doesn’t update.
  3. Switched to beta client, switched back to standard client - downloads in both
  4. “Continue without logging in” from login screen - still downloads
1 Like

i have the same exact problem and i did everything i could. but it just won’t stop.
i had to close after opening the game i want ,
and now i have to update that game to a new version, otherwise i can’t play it
but unfortunately i can’t update it , because i have to let beta download again to be able to update my game!!!
Help please!

Hi, same issue
did anyone find a solution?

as a last effort, I removed all permissions from my pc and didn’t work

I’m having the same issue

Same exact issue, most people probably don’t even realize it’s being downloaded in the background because they have good internet. Has this really been going on for 8 months? and why is the beta client being downloaded when I never opted to do so in the first place?

Same issue here, i tried to contact blizzard support, they told be there was a topic on this on the forum. I tried so many things to correct this but didnt find any solutions for now.
Blizzard support si one of the worst i’ve ever seen and seems like it’s not going to change since they ignored this topic for 8 month.