API request timeouts

I’m having an issue where all WoW API requests made by a bot that I run are timing out when I run the bot from its cloud space. If I run the bot from my home computer, the API requests are successful.

My bot has been using the Blizzard API for about a couple years now, and I haven’t had this issue before.

The timeout errors have been happening since yesterday when there were DDoS issues happening for Blizzard WoW servers–is this a related issue?

Thank you.

Edit: the bot normally runs from Digital Ocean.

I’m also experiencing this type of timeout, since the same time-frame. I can’t find any status regarding these issues.


1 Like

Happening to me aswell, works fine on local machine.

Anything I have hosted on Digital Ocean is not working.

1 Like

Same issue with Linode servers

Has anyone figured out how to avoid the timeout? I’m hosting on Amazon Web Services and getting the same problem. Would love to find a resolution.

In September 2019, Blizzard temporarily blocked some popular hosting services in an effort to mitigate a DDOS attack during the WoW Classic launch. This thread was created due to that action, which has since been rolled back.