A few questions

I have some limited experience with game APIs - I did some work with Eve Online’s for a while during a break from WoW.

I don’t know how the Blizzard system works, but with Eve Online the data was pulled from a repository that was between 1 and 60 minutes in the past. That repository was essentially a snapshot of the system at that point in time. Is that more or less how things work for the Blizzard API (might be different time intervals, but I’m looking for the basic structure of things)

We’ll start with that one and see how it goes from there.

Also, the Discord link doesn’t seem to want to work. Says something like “Unable to accept invite.” Not sure why on that one.

1 Like

Section 2 (Types of endpoints) of this topic might answer some of your questions.

Discord link should work fine unless you have been previously banned from it. Try using the link from a different web browser just in case.

If you have any other question or the link still doesn’t work, let me know and I’ll try to help.

Surprisingly I looked through that before posing my question. I don’t mean that in any sort of sarcastic way - it’s just an acknowledgment that while most people probably just drop by and ask, I did do a bit of research on this first including exercising my best GoogleFu which didn’t provide me with an answer.

I can’t imagine how I’d ever have been banned from that Discord as I’ve never dabbled in the Blizzard/WoW API before. I had a roommate until recently who did chasing some Auction House project that didn’t pan out but as far as I know she has her own account on Discord. We did share an IP address if that might matter.

Ah. I might have found something but it raises another question:

What happens if the client crashes instead of the player logging out gracefully? Is the data lost?

Everything in WoW happens server-side, so no, no data will be lost. I believe in that case, once the user session times out (player gets disconnected from the realm), it will be handled as if they logged out.


I did, however, start down the path of gaining access to the API and found that I already have.

Except I never did.

This is my first time.

I’m guessing my former GF probably used my credentials - she had issues with the 2-factor-validation on her account and I remember her trying to get it fixed. My guess is that she just used mine when I was not looking (I nap a lot).

I’ve no idea of she did the same thing with my Discord account - seems likely if she did the other work on my PC and on my account.

Any way I can find out if she horked up my access there. She’s a stroke victim and a big part of her problem was that she had absolutely no filter. I ended up having to ship her back to her family because I couldn’t handle the trouble she was getting into.

Also, it’d probably be a good idea for me to delete the project she started.

I’ve no idea what she might have done with this and she no longer has access to my phone (which has my 2-factor validation app on it) so she can’t do much with it anyway - but I don’t see a “delete” option on the “manage” page.

I can’t help much further with those issues. You’ll need to contact Blizzard support. There is no way of deleting an app from the web interface.

Keep in mind that what you described is a clear violation of the API terms of service and Battle.net account terms of service, so I’m not sure support will be able to help much.

You can, however, re-generate the client secret and expire all active tokens, so whoever used your credentials before lose the access.

Edit: Also, I’m pretty sure you can just rename the app from the interface.

I did that - and I didn’t ever give her permission to use my account. I wouldn’t, ever.

I thought she was working on her own - she stopped complaining about the 2-factor thing - I thought she’d fixed it.

Apparently she hadn’t. She just “borrowed” mine.

That’s part of why I had to ship her back home - her sense of what’s okay was kinda broken.

This isn’t the worst thing I’ve discovered that she’d done.

I’ve got about three grand worth of unauthorized credit card charges I’m disputing as well - had to get new cards sent.

It just never occurred to me she’d do this.

But I’ve already generate a new secret for my app - and I doubt she can get back in here to mess with it. Her new living arrangements don’t include access to a PC.

I’m pretty sure you are safe to re-use the same credentials for testing purposes. Also you can even create a new app and forget about the last one. They don’t share the same quota.


For now I’m just sort of digging around to see if I understand the data that’s available.

Can’t seem to get the “try it” option to work. I get a flash of an error but not on screen long enough to see what the error is.

I’ll keep at it.

BTW I just tested and the discord link is working as intended. Perhaps try joining from a different web browser/mobile app.

If that doesn’t help I would assume your account was indeed banned and you might need to use a new one.

Might take up to 15min to work after creating a new pair or re-generating the secret.

Yeah. That’s likely it. The token part worked fine but the part that needs my codes is showing not authorized.

The Discord isn’t a must. I just dislike that she broke it for me. I keep finding little things like this, both online and physically - reminders all that I made a good decision sending her home.


I couldn’t get this to work yesterday so I just stepped away for the night to let things settle (I renamed the project and got a new secret key - I thought perhaps it might take a bit to get all of that sync’d on the back end).

This morning I’m having no better results.

I’m just using the “try it” feature.

I’ve entered the key and the secret key and the token.

It appears that I have a token because “Clear OAuth Token” does appear near the results field.

I’ve got my own server name in place in the “try it” data (bloodfurnace - and I’m guessing that that’s how to create a proper realmSlug for “Blood Furnace”).

I’ve got one of my characters on that server in the characterName field, lower case.

All I’m getting back is a response status of 401 Unauthorized and a response length of 0.

I’ve attempted this with multiple endpoints and gotten the same result.

I’m not sure what I’m doing wrong here.