6/21/22 Unable to login to battle.net app with authenticator

After this mornings reset, I am unable to login to battle.net desktop app.

After filling out login info, then authentication token (from physical authenticator, not the mobile version) I get the following message:

Could not log in to Battle.net
More help: BLZBNTS800000011 (73)

  • Some games and features may not be available.
  • You may be prompted to log in again when playing a game.

I can login to the website easy enough, and my autheticator works there when I changed my password, and the rest of the troubleshooting steps, however I can’t launch the game.
Thanks!

5 Likes

same cant log in says i have not internet which is false then same code

3 Likes

I too had this error code : BLZBNTBGS80000011 (73)

I thought I finaly succeeded to log in because it put me in a queue (estimated time ~1min)
but I was still offline

2 Likes

hehe now it says their looking in to the problem well it could be do to the patch or them pulling the game down for maintenance you would think

2 Likes

Cant log in too in battle net account and in wow too

1 Like

I tried manually logging in from the game client, and still can’t get into the game

  • Enter credentials
  • Get a captcha (passed, I am NOT a robot. My mother will be disappointed)
  • Get authenticator pop up, enter token
  • You have been disconnected. (BLZ51900073)
1 Like

Hey there,

Just letting y’all know here that we are looking in to this. There should be a message in the Battle.net app now and we have a tweet up. https://twitter.com/BlizzardCS/status/1539292632693850113

We are actively looking into it and hope it is resolved soon!

/Nathardrick

3 Likes

same here, both for battle.net and wow :frowning:

2 Likes

call of duty is uploading the new season thru the floppy drive so blizzard is down untill they get more hard drive space cause the update will be 10035gb

YEAH… Still DOWN!!! Everyone else still have the same issue? I am now logged in, and it says ready for update… THEN… throws an error code every time I try to update still… even after restarting ect.

1 Like

Appears to be back up now, thanks engineers/IT for fixing
8^)

I can’t log in keeps telling me to reconnect and give and error code, but I can access my account and everything else just not WOW.

cant log into the game error 51900118
2030 hours

3 Likes

Bump :slight_smile: I have about 20 guildies spamming me that they are experiencing the same issue.

1 Like

Same here getting the 51900118 trying to get into Classic WoW. Reinstalled. Flushed everything. Rebooted router. All the usual stuff.

I haven’t been able to play Hearthstone on my laptop all day. When I try to play and log in through Facebook, instead of taking me to Hearthstone it says. App not setup. This app is still in development mode, and you don’t have access to it. Switch to a registered test user or ask an app admin for permissions. I’ve never seen this before.

Tried to log into retail, and that works, now when I go back to Classic its stuck looking for realms.

bro same situation with me not log and same error on my screen

I was just wondering if there is any update to fixing the problem with the authenticators? Mine works on my phone but my husband refuses lol to take his off the key fob and he can’t log in.