4k resolution scaling

Not sure why, but when I turned on my computer the battle net app was no longer scaling to my 4k monitor. I don’t think anything was installed or updated in the interim. Display drivers were last installed 20 days ago, so I’m not sure why it suddenly changed.

Hey, Ectar!

If the DPI of the app is too small/large you can right click on the shotcut for the Battle.net app, go to Properties, then go to the Compatibility tab and modify the DPI settings here. This will allow you to scale to your desktop resolution if you wanted. :wink:

The only applicable-sounding option I’m seeing there is “Disable display scaling on high DPI settings”, which doesn’t fix the problem if it’s checked or unchecked.
I’ve also tried each of the other check boxes in the compatibility tab, and none have fixed the issue.

If you are on Windows 7, I do not think it is possible to manually edit the DPI scaling of specific programs. Sorry about that.

You can try to do a clean reinstall of the app to see if it helps, otherwise I am unsure of a Windows 7 setting that can fix application DPI issues.

I had already tried that, unfortunately. Thanks for your time.

What’s the problem to make app compatible with 4k res? It was suitable in 2012, on the edge in 2016, but it’s really stupid shaming in 2021…

If you opt in to the beta launcher (go to the launcher settings) there is an option in the settings for High DPI Support. When you’re on a 4k monitor for instance and you scale your DPI to 200% in Windows (so that everything doesn’t look tiny), by default the launcher will look blurry. This new option will use higher quality assets so they still look sharp.

2 Likes

Thanks! That’s what I craved for. But I stay with my opinion that High DPI as beta in 2021 looks disappointing.

Now that the new launcher is out, what happened to the high DPI support option? I can no longer find it, it was there in the beta, but on live we are back to blurry fonts. It’s better than the jaggies we had, but still… :confused:

So for me now the Settings from post of [Ibaraius] work´s

Thank you! That’s sorted it. Was really annoying looking at a fuzzy app on my 4K monitor!