"wow51900319" Since servers online


Not seeing anything interesting in that WinMTR. Have you updated your network drivers and operating system and troubleshot/uninstalled your security? Sometimes we see this when network cards can’t handle the new instruction sets, or antiviruses mistake our updates for a virus.

If neither of these helps, you may want to put in a ticket. We don’t want you to go too long without being able to get in playing, and we can ask for better system files over the ticket system to diagnose this.

Still not working. I’ve deleted my cache, removed addons, rebooted my internet, disconnected and re-connected to my wifi, ran anti-virus, updated windows and my drivers.

Nothing is working.

Still nothing, thank you for the response but im at a very annoying loss

Okay, I finally was able to get into the darn game, but now, nearly all my Horde characters immediately get DC’d upon logging into the world. HOWEVER, my 110 Warlock can log in and a lvl 1 Orc warrior can log in (I tested it, no, location does not matter. My 110 Paladin got DC’d in Dalarn yet my 110 Warlock did not)

Every single one of my Alliance characters can log in and play just fine. This is weird as all gets out

Has anyone in this thread had any measure of success? I’ve tried 18 different items Blizzard suggested and nothing has changed.

1 Like

Not at all. I just re-installed the game, and now I’m back to it kicking me out as soon as it attempts to get to the character screen.

Sounds like we all need some remote log in assistance

constant dc issue and this error , over and over, Please fix this Blizzard. There is definitely some issue here. No issues at all before the previous mini patch

No luck here. I also tried all of their suggestions with no joy. Still getting 51900319 after about two minutes in game every time.

Same issue as me. My highest character is 104 as I’m a new account.
It doesn’t seem to care what location you are in.
From new level 1 to all ranges up to my 104 it will not let me log in 98% of the time.
I have managed to play a little bit today but the second I log off it goes to the error instead of the character selection screen then it stops me getting back on.


Do you happen to have a Killer network card? If so:

  1. Open Killer Control Center (can be done from windows search)*
  2. Click the settings cogwheel in the bottom left
  3. Disable Advanced Stream Detect
  4. Retest

*If you don’t have killer control center installed for your killer network card, grab the suite from Killer’s website.

From what we’re seeing some quality of service programs are setting the new build of WoW to the wrong priority, which makes it disconnect. We’re even seeing really odd behavior like it only affecting certain characters on certain servers, but nonetheless disabling the quality of service (QoS) settings fixes. Any luck this way?

If this works, you can also manually set World of Warcraft to Priority 1 in the apps settings. If you need help with that I’d contact Killer’s support team or do some investigation online.


Same issue here.

I did this and it worked. Hopefully forever. Thankyou for the reply to this and have a good night.

woot!! it worked, thank you, thank you

This finally worked!!!

didnt fix it for me. still running into the disconnect error.


You’re probably having a different error than these players. The WOW51900319 is just the generic error we display when we don’t know what’s actually going on with a connection problem because we don’t have enough information to determine the cause at the client level.

If the solution here didn’t work, please create your own thread or contact our support team for direct help - someone should be able to shoot you straight. If you can catch your connection issue with a winMTR test and either attach it to the ticket or post it, it’ll help us sort you out faster.

The Killer N advice worked for me as well. Thank you

Worked for me too!!! Thank god. Most annoying to not be able to play over WiFi.

Thanks Drakuloth.

I’m a returning player after a 2 year hiatus. I’ve been getting this disconnects frequently since I came back when 8.0 was launched. I don’t think it’s an 8.1 issue, and I was beginning to think the issue was either with my home router (Luma) or AT&T U-verse service since the WoW troubleshooting steps didn’t resolve anything.

I just disabled the Advanced Stream Detect on my Dell G5. We’ll see if that fixes things.