WoW Companion App stuck on Connecting after 8.2 update

Ever since the update I’ve been stuck in Connecting. I’ve tried restarting my phone and uninstalling/reinstalling the app. All it does is says “Connecting…”, after a while the Cancel button will disappear and it will sit on Connecting for hours if I let it. It never gets any further.

1 Like

Hello Triovana,

Can you give me some information regarding the type of phone you are using?


I am having this issue. One Plus 7 pro. Android.

It’s a Samsung Galaxy S9.

Also, the forum changed the character I was posting with (I didn’t change it, I logged in and replied and it showed a different character) and the characters are considered separate entities for some reason. What a mess.

Same issue here. I have a Google Nexus 5X.

Had an update this afternoon, seemed to download and patch fine. Still stuck on connecting. At one point it progressed to Unable to contact battle net. Reinstalled, rebooted, all the tricks, no change.

Yep, same here. Updated, still the same problem.

Also having this issue on my samsung Galaxy S9.

Please help!