Worgen Heritage armor questline broken

Currently not working, Goldrinn just disappears and you can’t grab ‘let sleeping wolves lie’. Leaving you with no way to complete the questline.

1 Like

Confirmed. When you try to accept the quest “Let Sleeping Wolves Lie” from Goldrinn, he vanishes, and you are left standing on the platform with Tess and Vassandra.

1 Like

Has there been any update to this? I am also unable to get the next quest and I can’t get any resolution via in game systems.

1 Like

It seems that, unsurprisingly, this bug was never fixed as I experienced it on live myself.

Just solved the issue by relogging, still very annoying though.

Same bug for me, the princess falls asleep and I am standing around in awkward silence near the elf.

Logging in and out fixed it.

Confirming this is STILL broken.

yep still broken, I completed Walking a Dreamer and then Goldrinn just vanished

UPDATE! I just relogged and then Goldrinn showed up! Try to re-log in-front of the portal at The Twilight Grove!