Urgent Care, Kelsey Steelspark is missing

I Look around Boralus Harbor, I try log in and out, Drop the quest picking up, I try zone in and out and nothing is making her spawn where quest area say she there, Also they say “have you try ship” She there but no “?” please fix this just Hot fix a NPC Kelsey Steelspark for this quest case what ever I am in war campan is messing this up.

12 Likes

Also missing Kelsey Steelspark.

I been Toon hoping around so far 3 and none of them Have seen her Like is there some thing wrong here or what?


Seems you need to unlock Mechagon on the Alliance toon as well. But even that might not work. I’ve just finished unlocking the Island and still no Kelsey

1 Like

I also have Urgent Care but there is no Kelsey Steelspark to be found.

Have a DK that has Urgent Care (and mechagon opened up_), and a Druid. Both can not see Kelsey at Boralus Harbor.

Still no Kelsey at 9:27 pacific time. Hopefully she returns from her break soon… otherwise we’d better start an investigation on who punted her.

1 Like

ive had it completed for a long time and i cannot find Kelsey, both alliance and horde achieves are done. still cant see her, yet i am seeing other people with the mechagnome…

They probably unlocked them prior to the hotfix.

Having this same issue. Cannot find her anywhere. :frowning:

Same issue.

Same here as well.

1 Like

I try all my tricks, loging in and out, many times, Leaving the game and loging back in, going in and out of instance, Going zulzar and back and try 3 different alts to get her to spawn but no she will not show up

3 Likes

Been trying to get my Mechagnome warrior going for hours now. I keep checking back for Kelsey. Still not there. I guess he’ll be a day behind everyone else. Thanks Blizz.

1 Like

Kelsey Steelspark is missing for my Alliance Alt as well.

I was given the quest in SW Embassy.

1 Like

This questline seems rough from the start. First I had issues starting now, now Kelsey Steelspark is missing.

Even just a little boost to the next part of the quest would be great

i just saw people unlocking them. How in the hell? I still can’t see kelsey.

3 Likes

No idea. I’ve been at this fountain for hours non-stop waiting on something to happen

I just logged off my Vulpera to see if anything had changed… No Kelsey at the Fountain… still. How vexing.

2 Likes