Upper Kara - Shade Flame Wreath, possible bug, not really able to tell what's going on

Was in a group yesterday and we hit a brick wall at Shade. His flame wreath kept exploding the same exact server tic his cast finished. We spread out in all different patterns, no one moving, jumping, anything. No matter what we did, everyone would explode immediately when the cast finished. There were a couple attempts where the circles would appear on a couple people, then like 5 seconds later all of a sudden everyone explodes, still no one moving at all. I tried google and found a few posts here and there about some warlock pets and Bron triggering flame wreath, but nothing like what we were experiencing.

I like to think I’m not a window licker, but this has me stumped. I really have no clue what we were doing wrong. We were spread out really far and everyone was perfectly still, not even jumping. Still, explosion immediately when the cast finished.

Is this happening to anyone else? I’m aware the tuning is wack as well, but that’s not the exact issue I was having.

Yes, had same issue in my 14. We think demo lock pets were setting it off. Also, it was going off if anyone died inside one too.

We didn’t have a lock, but we had a hunter and 2 Brons. Me and the other guy with Bron clicked off the stacks before they got full just to be safe, was still happening consistently.
The only upper I’ve been able to time has been one where he just never did flame wreath. Talked to a half dozen other people in game that have said the same thing, could only do it if he just never did flame wreath.

quaking appears to set it off, from what my groups have observed