Unable to Update game

When I was playing the game, I realized I needed to install a new mod for my game. So I closed down the game only to be told that the game needed to be updated. However while it was fetching, the update crashed and was told to go to this web page.

I tried each of the suggestions to no avail. That includes using the repair tool, forcing the Windows Firewall (I use no other security program) to allow the Battle.net app, running as administrator, uninstalling and reinstalling the app. I then went and tried to uninstall then reinstall. But AGAIN while trying to install, the program crashed while fetching data. and sent me to the same page. I’m getting extremely frustrated since I don’t have a lot of in-game time and I have a LOT I want to get done.

Having the exact same problem. Same error and doing everything they suggest does not work. It is on their end.

me as well guess its not our computers…lol

Same… did everything that was suggested and still getting the error. Hopefully it’s resolved on their end quickly… Very frustrating

Same, the launcher gets to “Initializing…” then “Checking residency ###/###” then a split second later it fails.

UPDATE: After restarting and logging into the client for the first time. it starts to update then nothing happens, but the update button is clickable. Then it fails again… Might be related

Same here. It looks like that not everyone encounters this problem.

update: I did the repair a 3rd time, restarted a 3 time and I can log in. Maybe the 3rd time is the charm?

So I found this post from a few days ago, and it APPEARS to be updating now but still frustrating. I didn’t need to restart my PC


Tried it and works great! Thanks!

That worked for me as well. Nice find!

you that man! thanks a lot, your faster then blizzards customer support!

The absolute bro tier guy right here.

I have had this happen many times and it is a simple fix, bring up task manager and look through the processes toward the bottom there is a wow voice proxy sometimes there is two of them. Right click on it and end it and then restart wow. You do not have to restart your pc


Worked for me, too! Thanks!

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.