Unable to install games/patches or uninstall/reinstall battle.net

To preface this I have gone through the KB and the fourums and nothing is helpful.

I am unable to install or update anything.
I am unable to uninstall the battle.net app.
After manually removing the battle.net app I am unable to install the battle.net app.
It’s all stuck in permanently trying to update.
I am looking for a way to manually remove the update flags, or to bypass download/update authentication.

The errors I am getting are that I am waiting for other updates for when trying to install or update a game, or something went wrong when trying to install battle.net.

I want to reiterrate here that none of the existing fourum posts or KBs have been helpful in this regard.

I tried removing all of the files from the machine manually, so I transferred them elsewhere just in case I was unable to install. per fourums.

I also have deleted the cache from Program data and Appdata Local and Roaming via removing the
Battle.Net and Blizzard Entertainment folders. per fourums.

I have also tried the WMI cache reset to no avail. per KB

My security software is Windows Defender and I also disabled that to no avail, so I re-enabled it after trying. per KB

The app is running as Administrator. per KB

I have done all of that in many different orders as well.

And yes I have restarted my computer… alot.

I changed the owner of all involved files to the Windows version of the ‘root’ admin account making it so that this program more or less has totally unfettered access past literally everything except hardware security. Per KB

My computer is completely up to date, and is also only a couple of months old which means this is more or less a new admin profile. per KB

The only thing which seems to work is to quite literally install it on another machine and then manually move the files to this one. Which I find both frustrating and amusing. Nobody even suggested this one because it’s really dumb, and probably screws with the registry. Why solve problems when you can just bypass them right? lol

The relevant log information is as follows:

Response 401 (0.0100 ms): {}
[W 2022-08-10 21:51:37.0596] Unable to acquire processName for PID 9068 (PID for Battle net according to task manager)
[W 2022-08-10 21:51:37.0596] Authorizing client ‘’ (9068) for communication
[I 2022-08-10 21:51:37.0597] Request GET /agent
Response 200 (1.7300 ms): {
“authorization”: “HASH VALUE REMOVED”,
“opt_in_feedback”: true,
“pid”: 15440, (PID for svchost.exe which I do not understand why)
“region”: “us”,
“session”: “HASH VALUE REMOVED”,
“state”: 1004,
“type”: “retail”,
“user_id”: “HASH VALUE REMOVED”,
“user_name”: “HASH VALUE REMOVED”,
“version”: “”
[I 2022-08-10 21:51:37.0617] Duplicate POST /install/battle.net completed in 0.6160 ms
[I 2022-08-10 21:51:37.0632] Duplicate POST /install/battle.net completed in 0.4300 ms
[I 2022-08-10 21:51:37.0633] Duplicate POST /install/battle.net completed in 0.4940 ms
[W 2022-08-10 21:51:43.0104] Request DELETE /agent
Response 200 (0.8060 ms): {}
[I 2022-08-10 21:51:45.0869] No Connected Clients detected: Shutting Down
[I 2022-08-10 21:51:46.0764] Agent is shutting down

My actual job is application support, so I understand how to Windows and I need help from a bigger more powerful support agent.

1 Like

Maybe you’re having trouble communicating with the CDN. Have you tried a new DNS or alternative connection?

Hi, thanks for that. I have just tried that. Previous was allowing DNS assignment via DHCP, now I am on the Google DNS. This did not help.

I am also getting the battle net updated has gone to sleep error. I know it is caused by a 401 error because of the logs from above. It’s triggering because the updater is failing to authenticate, which I think is where the troubleshooting needs to get aimed.

This is consistently happening even if I blast out the cache which contains the actual updater application.

Normally I would just reinstall it, but I can’t uninstall or install it lol.

I checked my power settings to make sure my processor wasn’t just trying to go to sleep or something. Just for good measure. This didn’t lead anywhere.

You can check the connection to the auth server with the looking glass tool. Also, an MSInfo (after export) might hold more clues in the error reporting. It’s up to you if you want to post one here or post it privately in the ticket system. Blizz doesn’t ask for them on the forum, but I don’t work for Blizz.

1 Like

In the WMI I am getting this error. I already tried a WMI reset so I need to troubleshoot it differently. Also basically anything that needs to touch hardware or an installer is throwing this out so my logs are spammed with a few thousand variations of this same identical error. The processes referenced in this are battle net, which I still can’t install or uninstall because it also throws out this error lol.
Id = {00000000-0000-0000-0000-000000000000}; ClientMachine = OBSIDIAN; User = OBSIDIAN\Administrator; ClientProcessId = 13188; Component = Unknown; Operation = Start IWbemServices::ExecQuery - root\cimv2 : SELECT ProcessId, ParentProcessId, ExecutablePath, Name FROM Win32_Process WHERE ProcessId = 21068; ResultCode = 0x80041010; PossibleCause = Unknown

The System throws this out.
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
I tried to troubleshoot the DCOM, but somehow my super admin account doesn’t have the ability to change permissions for itself or a normal admin account. Even if it takes ownership over the applications in question. And for whatever reason none of them have NTUSER as a valid user who can control them.
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

I ordered a factory reset USB from Lenovo so I a guessing my fix is going to be a reinstall of Windows.

I answered my own question by complete accident. Apparently my whole WMI was broken due to an invalid class. I tried to post a link to the solution but it said I am not allowed to.

It still took some work, but I hope one day someone else needs to fix this exact problem.

You can post the link by encapsulating it with grave accents (`).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.