Torghast Not giving anima power on entry

zoned into layer 4 and 5 of this weeks wings with a partner. I had already cleared those layers, he had not. The first time we zoned to layer 4 i got an anima power. proceeded to not complete the run and exited, changed specs, and started again, i did not get an anima power on entry but my partner did for our next two runs.

2 Likes

I am having the same issue. It occurs on group. All 4 other party members but me are able to select a power.

I am also experiencing this. I will never get a starting anima power in torghast but ONLY when i’m in a group. When I’m solo it works just fine. All other group members will get their anima cells but me.

problem persisted this week and last. Only did torghast with the same one other person. i had not done torghast at all yet in the week and when zoning my partner had an anima power and i did not. In addition for the first floor of each wing i did not have the debuff applied to me but my partner did. the debuff was applied on the second floor.

This is also happening to all my toons :frowning: i just call it bliz bugs tbh

I also have this issue

still not fixed and I’m still experiencing this issue

I also get this bug, have had it since torghast started.

i have this issue also.

Came across this issue today. While not a biggy in the long run, it kinda sucks when you miss out on a good startup power.

anyone know if anything is happening about this bug?

I am also receiving this bug on my monk when in full parties. It seems going in solo or in a party of 2 at least I still get a power.

also happening to me, solo or in group with another person, on multiple characters. tried changing graphics settings, reloading, resetting the instance. it’s not the chorus event b/c it happens on the save ____ quest runs too.