Timewalking has serious issues for characters below 70


I very rarely post anything here, but yesterday I tried to do some timewalking leveling with a friend and I can say that in our 18 years of playing this game together we have almost never encountered something so broken.

If you aren’t familiar, Let me break this down for you. I am ordering these issues from worst to most benign, but really this whole system is unserviceable.

(The below conclusions are from testing on almost 20 different characters across two accounts between the levels of 30 and 60)

  1. Timewalking will often NOT show up in any form in your group finder if you don’t meet all the requirements. This is completely counter intuitive because in most instances if you don’t meet the requirements for a dungeon or raid queue, the option will still appear but will be greyed out. This is helpful because mousing over the grey text will show you what you are missing (levels, item levels, etc…) Here you are just left scratching your head if timewalking is evening happening.

  2. The item level requirement seems wonky for low level characters. If you didn’t know there are seemingly random item level requirement for leveling time walking dungeons. Yesterday during our testing we found the following:

Level 41 awful gear: Couldn’t queue
Level 36 Full Heirlooms: Couldn’t queue
Level 35 that had just claimed a gear update: COULD queue

Again, I can’t actually tell you what the required item levels are because there is no greyed out menu option in the dungeon finder that tells you.

  1. Interaction with Chromie Time: In order to queue for a timewalking dungeon you have to manually remove yourself from chromie time. This isn’t advertised anywhere in game. There is no justifiable reason this shouldn’t just be a pop up when you try to queue. So again, if you are in ANY chromie time era, the timewalking option WILL NOT SHOW UP AT ALL.

  2. The level requirement. I’m sure the level requirement for cata timewalking is clearly posted in some blue post, but honestly we really didn’t want to start our evening game session by researching blue posts. We found out the minimum level is 35 by testing various characters. Again there is seemingly nothing in game that tells you it is 35. Also, this goes without saying but 35 is a totally arbitrary number that doesn’t sync up with any in game milestone associated with Cata.

We played for over an hour last night, did zero dungeons, and logged off upset. Please fix some of this.


I am confused, I thought that you had to be level 60 to participate in timewalking events? It squishes you to 35, but I thought you had to be at least 60 to queue?

I had no problem leveling my monk from 65-70 yesterday.


thank you for this, i could not figure out why ONE toon couldn’t queue, it was because of chromie time.

Im also a bit confused.

I was under the impression that timewalking just worked for everyone, and that’s why Timewalking weeks were usually the best time to level a character.

Did it change?

if you are in Chromie time, you are already Timewalking.

if you try to timewalk while you’re timewalking, some weird Dr. Who stuff would happen.


lol a paradox.

1 Like

*Xzibit has now entered the chat.

“Yo dawg…”


Pimp my dungeon?

1 Like

lol ran tests….I just figured you had to be 35 as that’s what you are squished to. The Ilvl requirement is 90. Leveled a few toons through love the xp buff

See now I did TW dungeons yesterday… it swapped to Legion TW today and now it’s not giving me the option to queue for TW.

I’m already aware of the Chromie time thing, it was already turned off tho. I turned it on and off again just for s & g’s… nada. I’m level 41, ilevel 107. This stuff doesn’t make sense.

*Annnd I think I figured it out… Legion is apparently lvl 45 req.

You have to be whatever lvl the expac’s lvl cap is. Legion it’s 45, tbc and wrath are 30 and such just as a heads up for you and others.

I’m walking on time lines