The Battle for The Undercity Quest:

I have been trying to do this quest for a while now, however it is still very much bugged. Varian has decided to charge in on his own (I never spoke to him to even start the quest) and is now in constant battle with Sylvanus and Thrall. I am very confused on what is even going on, I have tried multiple things, hearthing away, reloading UI, turning off all addons, phasing in and out of a dungeon to try and reset the question. Nothing has worked, some help would be appreciated!

1 Like

I generally have a very scathing opinion of blizzard’s development and player support practices. But I also believe it’s important to recognise and acknowledge when things are done well - especially if you want to see improvement.

So with that I wish to say that I really appreciate blizzard’s open and honest feedback here:

  • The negative experience was acknowledged.
  • The cause of the problem was explained.
  • A short-term stopgap was put in place.
  • And most importantly, there was follow-through to resolve the underlying problem within a week of the original post.

So, thank you.
(Arthas voice) FOR NOW.