Streaming the game with discord causes the game to deadlock

any time I stream wow classic (only classic not retail) my game will randomly crash and be impossible to close, becoming a zombie process that whenever attempting to close says “Access is Denied”, this is because the process crashed while doing something in the kernel thus making it impossible to close, the only solution to my new zombie wow classic is signing out of my computer and signing back in (this works cause windows is just closing anything associated with my login session) I would like to be able to stream the game without it crashing, if you have any solutions or people to contact to try and get this fixed let me know, I doubt this is a problem on discords side and I have confirmed it not to be an addon problem.

While making sure the game client works in conjunction with third-party software is not officially supported here, I decided to go ahead and test Classic and TBC streaming to Discord. Both worked without issue, so you’re likely hunting down a problem exterior to the game client.

this only happens to wow classic TBC and no other game on my system, and this only started happening after wow classic updated to TBC, if I stream the old version of wow classic it doesn’t crash in this way. There could be a million and one reasons why its not repeatable on your pc. Different hardware, drivers, etc. Like I said its happening in the kernel so your windows version could have different syscalls which don’t lead to the crash, I’m personally on win10 1909, maybe 20h2 doesn’t have the crash, I don’t know as I’m not on 20h2. But the main point is it happens every time on mine. That’s why I’m asking for a solution from someone who has experienced the same or to get someone to contact as blizzards support system no longer lets you send in tickets.

You have to post actual information that can be used to troubleshoot.

You haven’t.

Post a dxdiag, and know that updating your windows install is going to be one of the first things recommended.

nothing in DxDiag is the problem my graphics card drivers are updated and my system is on the latest update it’ll let me be on, the issue is something in WowClassic.exe is deadlocking after making an IPC syscall, this is an issue with a kernel windows driver nothing to do with my graphics card, I cannot update my windows version as 20h2 is not currently offered for my machine, I’m stuck on 1909 until my pcs manufacturer pushes the update, I doubt blizzard would like me uploading a minidump file from my game at the time of the crash so until then I’m stuck giving you the information I have already given you, streaming TBC in discord on my pc causes it to randomly hang and become a zombie process, through looking at the minidump file from the crash in IDA pro I’ve found the issue to be like I said a hung syscall via IPC, which then causes the game to stop functioning and become a zombie process as its permanently waiting on a response from this kernel driver.

Then it’s on you to solve it. It is beyond the scale of this forum.

And paragraphs.

“post troubleshooting info”
I post info
“lawl on you to solve it”
thanks for being useful.

Kernel level is a system stability issue. Tgifs forum troubleshoots wow, not your whole machine.

you are unable to read, all applications use the kernel to communicate with your system at a hardware level, there is an issue with an IPC syscall (which goes through the win32 kernel) this syscall is being called BY WORLD OF WARCRAFT and is therefore a WORLD OF WARCRAFT issue. Please don’t act like you know what you’re talking about to farm posts to get MVP when your first instinct with a syscall issue is asking for DxDiag.

Attacking other forum members is not the way to encourage people to help you with this. Their approach is direct, but accurate. The forums are a player help player area for the most part. Your DxDiag error section or the error reporting in an MSInfo might point to other clues as to why the clash is happening. All new tech support posts for issues like this one should include at least the DxDiag (requested in the pins by staff), but one hasn’t been posted yet.

However, if you are not interested in troubleshooting here and feel your concern is above us, please do go ahead and submit a ticket to Blizzard so you can work with their tech support staff. It does seem you will find the same info I’ve already provided (i.e. third-party software compatibility is outside their support), but maybe they’ll surprise me.

their ticket system doesn’t work, go through their support site and tell me if you can find a way to actually submit one because everytime I’ve tried to submit a ticket it sends me in an endless loop of FAQ articles.

You have to click the Contact support button. Sends you here: