Strange video artifacts in 8.1.5


(Stoneblade) #24

Nope. As you’ll read above, the AMD card is my Macbook Pro.


#25

Would you be able to link a config for your MacBook Pro? It may help since that seems to be the only known AMD card affected and Blizz may be able to replicate the issue from there, as their Macs all apparently use AMD cards.


#26

i have this issue as well, started recently, when i am moving there is a strobing effect of ground clutter appearing and ground clutter disappearing. IT ruins any game play I have because it happens every time i move! here is my system : |Model Name:|iMac|
|—|---|
| Model Identifier:|iMac14,2|
| Processor Name:|Intel Core i5|
| Processor Speed:|3.4 GHz|
| Number of Processors:|1|
| Total Number of Cores:|4|
| L2 Cache (per Core):|256 KB|
| L3 Cache:|6 MB|
| Memory:|8 GB|
| Boot ROM Version:|133.0.0.0.0|
| SMC Version (system):|2.15f7|
| Serial Number (system):|C02NP167F8J5|
| Hardware UUID:|2F5AE160-387C-56D1-AB56-2D2A41FF1AED|


#27

ruins my game, seems to be ground clutter striking on and off— here is my system : |Model Name:|iMac|
|—|---|
| Model Identifier:|iMac14,2|
| Processor Name:|Intel Core i5|
| Processor Speed:|3.4 GHz|
| Number of Processors:|1|
| Total Number of Cores:|4|
| L2 Cache (per Core):|256 KB|
| L3 Cache:|6 MB|
| Memory:|8 GB|
| Boot ROM Version:|133.0.0.0.0|
| SMC Version (system):|2.15f7|
| Serial Number (system):|C02NP167F8J5|
| Hardware UUID:|2F5AE160-387C-56D1-AB56-2D2A41FF1AED|


(Sagerremeseb) #28

Ok, after wandering around it’s clear the flashing is not gone with ground clutter set to 1, but it sure is a lot less noticeable.

And hey, I’ve got my avatar back.


(Chroesire) #29

I’m getting ground clutter flashing in all BfA zones at least (haven’t checked elsewhere).

  • 10.13.6
  • 2560x1440
  • 980Ti
  • Nvidia web drivers 387.10.10.10.40.122

Some footage recorded with QT Player, starting point at 32.77, 68.79 in Stormsong:


(Stoneblade) #30

It’s like that in Darkshore for me. On both nVidia and AMD.


#31

Hey all,

Has anyone tried Window Mode vs Full Screen to verify any changes there? You can use Command+M to change this any time to test things out.

Be sure to also reset game settings to default. If this works, change settings back to the way you had them one by one until you find the culprit. If this does not help definitely let us know.


#32

I tried windowed-mode after resetting my game options. Not only did this not help, but it actually caused the game to freeze up. I have the NVIDIA GeForce GTX 780M and am running Mojave 10.14.3


#33

I went back to the Stormsong cave take a video and the artifacts are gone. I imagine restarting my machine fixed it though there have been some game updates since I visited.


(Omegall) #34

The artifact issue should have been fixed by todays patch. the flickering doodads/clutter however is not yet fixed.


#35

I can confirm I’m not having anymore issues with artifacts, but yes the stuttering grasses/doodads persists. Still, the lack of black mountains is a great start!


#36

I have same issues when I can play. Most of the time I am only in game for a few minutes, sometimes seconds and suddenly my fans kick on and I lose all video. Only happens in WoW and all of this started after patch.
27" iMac late 2013
3.5 gig intel i7
16gig 1600 Mhz ddr3
4gig nvidia gtx 780m
mojave 10.14.3


#37

I have the same issue. I also get where I go to 1-5 FPS and the game almost freezes. Restarting wow fixes the lag, but the grass/flowers do the same for me in certain zones. :frowning:


#38

Hi all, I’m gonna chime in on this - hopefully this might help someone else. I had the same issues as above (ground jittering and weird artifacts) which started about a week ago. I didn’t think much of it until the weekend when my game complete froze and the graphics on my screen turned into something my '88 Amstrad would produce. Fast forward 3 days later and now I can’t last 5 minutes in game until I have a massive crash and my comp restarts automatically. The funny thing is, after my computer restarts, I can crash at anytime in Finder (usually within 5 minutes) without even starting WoW. This repeats but gets worse each time the comp restarts, until I manually shutdown and wait 30 minutes, when I can use Finder again.

Things to note:
• The problem is occurring in High Sierra and Mojave (I updated to see if that would fix it).
• This problem starts in game.
• I have tried setting my gfx settings in WoW to the lowest.
• I can force the crash to happen faster when I get my toon in an area where the gfx has to render some distance ie. Zuldazar and i look at a distance across the water to the high mountains.
• I have tried Diablo and the same thing happens after 5 minutes. I’m about to test Dota and HS.
• I have been playing WoW on this computer for 3+ years without a hitch.
• My work requires me to use programs like pshop and premier (sometimes the files get up to 2gb) and this doesn’t cause any issue.
• I have tried Cinebench and it passes without a hiccup.

System
27" iMac late 2013
3.5 GHz Intel i7
16GB 1600MHz DDR3
NVIDIA GeForce GTX 780M 4096 MB
Mojave 10.14.3

I thought my GPU was shot until I read this post. Thank you all and good luck.
J


#39

If you haven’t already I’d try to do nvram and smc resets. It’s possible that a driver crash by wow corrupted something and it’s carried over. I’ve only had a single crash that carried over into the rest of the OS with graphic anomolies, and did a restart / resetting of everything afterwards. Won’t fix anything in game though from my experience :confused:

SMC reset: support. apple .com/en-us/HT201295
NVRAM reset: support. apple. com/en-us/HT204063

Wow blizzard, make it stupid hard to give direct links to information thanks! (Apparently can’t have links even to Apple in the Mac forum). Also couldn’t link an image before to show what kind of issues I’m seeing.


#40

Cheers Ecklcras. Yes, I’ve already zapped the ram and smc with no luck.
Just an update…
• I tested Dota and Hearthstone and replicated the crash same as WoW.
• I spent 3 hours last night with Apple live chat testing the usual things (again) like creating new user, safe mode tests, re-installing os… nothing worked. They said they were unaware of any of these issues with drivers and that nothing like has appeared in there system. I showed them this thread and he acknowledged that it could possibly be a driver and that I should download a new one from nvidia (there hasn’t been a new driver update from them since 2015, so no I didn’t). Anyway, I’m booked in with a “genius” at apple store this morning.
• Blizzard responded very quickly to a ticket on this saying that there aware of the issues from last patch and that there monitoring this thread. 10.14.4 is now live today and I should give that a crack. Sounds like a goer!
Cheers, J


#41

I’ll run the 10.14.4 update tonight sometime, but I don’t expect any improvement on the basis of this post:

Be curious to hear if the Genius bar comes up with anything though.


(Caterpepi) #42

Thanks for the reports, everyone! We’re continuing to track this issue, but we’d like to gather a bit more information of each system.
Open the Apple Menu, select About this Mac.

  • Include Mac OS X version
  • Mac Model - Example: MacBook Pro (15 inch, Mid 2014)
  • Post the Processor, Memory and Graphics

(Omegall) #43

Typically, it’s actually better to use the feature built into wow client. go into help menu and choose “gather support information” then paste entire thing here. You may not be able to do this without first going into windowed mode though so you can see menu bar.