Stick it To 'Em! Bug

I was standing there reading this thread when the griffins rephrased on their own. Was able to mount after that. Sat for about 2 mins not clicking on anything. 3/2/2020

1 Like

Thank you. That worked for me.

Still bugged. logout and back on one toon yesterday worked… but today on another toon it did not. I had to skip it and travel on my own for turn in.

Still bugged. Pretty pathetic given that this was reported a year a go.

I had the same problem, but this worked for me: -
I got on my own mount. Then I dismounted. I was then able to mount the quest griffon and was flown to Arom’s Strand.

1 Like

Had the same issue today (04-15-20), but apparently walking to the edge of the cliff overlooking Anyport worked. I went AFK, and when I went back to check on the gryphons, which had landed fully by that point (standing on the ground), I could mount the second from the right.

Hi,
I think I found a way to make this work. You should still have the icon on screen for the fiery liquid you throw at the wooden contructs. I found that by throwing it, select it and choose an area away from all the npcs, as soon as I had thrown it I then was able to mount the Waycrest Guard’s Mount without a problem. No idea why though.

1 Like

This actually worked for me. Thank you!

That actually worked for me as well, thanks! Just want to bump this post again though in the hope that it gets fixed eventually.

Can confirm the issue is still happening.

This is a bug that is still happening today. Don’t think it will ever be fixed.

worked for me once I did the anyport questlines

This issue is still a problem. I had it just now. Just had to travel back manually.

found a fix lol i was like wowwwww okay so all you need to do is walk away from the gryphons head towards docks again then come back up and it fixed it for me hope this helped!

bumping this because as of today this is still a bug, I could not mount the gryphons and this was before and after restarting my game

Spent a few minutes clicking everything like a mad man, logged out and back in, nothing seemed to help. I took a min to read some comments, and when I came back it let me mount. Needs a undistracted minute to figure itself out I guess.

Still bugged.

Hah, and here we are about a month or so away from Shadowlands pre-patch and it’s still not fixed.

And they say the “Blizzard polish” is a thing of the past. Pshaw.

as of mid August, in the SL PTR, this bug is still there (reporting it anyway, despite it having likely been done countless times previously lol)

This quest is still bugged