Spires of Ascension FPS drop post 9.0.5

It may not be an incredibly widespread issue, but its widespread enough that there are multiple reports on these forums and over the EU ones.

Clearly something changed with 9.0.5 and its causing problems for a bunch of people that didn’t suffer with them before the patch, myself included.

I’ve tried all suggestions on this post and many others, to no avail. At this point I’m just looking for way to fix this issue and have the same performance I used to have before the patch.

1 Like

Around this same point in time there were also two Windows updates and multiple GPU driver updates. So it’s not as simple as blaming a change in the game when there are thousands (millions?) of others not experiencing it.

You right, it is possible that 9.0.5 didn’t change anything, but I’m having zero issues with other games or programs (along with a lot of people that have been putting in reports about 9.0.5 performance), that’s why I ruled out these other factors.

Also, none of the suggested “uninstalling updates” or “drivers rollback” fixes worked, that’s why I highly suspect of 9.0.5.

Anyway, whatever the source of these problems are, I just hope it gets fixed soon.

100% there is an issue with spires since 9.0.5 my gpu temps have gone up a good bit 5c or so ONLY in spires and i would bet its related to the fps drop issue as well.

Keep in mind ive done mythic slg, mythic denath etc bosses with a ton of stuff going on have never hit the temps im hitting in spires and only spires post 9.0.5

It’s definitely a issue with the game update. I’m running on an iMac and the issue started when the game was updated. Only thing common between the different OSs is the game update.

FPS is slower overall since the patch, but SoA is the worst offender.

1 Like

I have definitely found SOA unplayable since the patch. If I turn the camera a certain direction, the fps shoot back up to something playable but I can’t run around only looking in one direction doing mythics.

Same here Mac user and basically can’t run SoA at the moment and Oribos gets it too.

So I was able to significantly reduce my frame drops in spires by doing this.

  1. Went to Nvidia Control Panel 3D Panel>Adjust Image Settings>Let 3D application decide.
  2. Change battery settings to max performance
  3. In game Graphics I hit recommended. What I saw change was most of my graphics settings went to higher settings the most noticeable change was the Anti Aliasing option in the top right changed to none. So I think maybe issues are linked with this setting?
  4. Under Advanced Settings I changed graphics card setting from auto to my Nvidia graphics card.

Hope this helps someone. Seemed to work with me. I only had one frame hiccup during the whole dungeon but it was because I was stuck in corner with everyone else so spell effects probably made it drop last boss room. No other drops.

I tried those suggestions but unfortunately it did not seem to help my performance in SoA and other affected areas.

MacOS user here. I’m running the last version of the Mac Mini with an i5 intel chip (non-M1 Mac, as they are incompatible with an eGPU) and 16 GB of ram. I have an RX 580 8GB eGPU and am running the game at 1440p. I had zero issues with SoA, Anima conductors, and Oribos before 9.0.5. Even lowering the resolution and the settings to 1 doesn’t solve the issue. SoA is unplayable, even at sub 1080p and with 1 settings, as I still get a lot of sub 60 drops.

The issue has yet to be addressed. Sad

There was a post on the EU forums with a possible fix, I tried it (except for the first step as suggested) and it seemed to significantly improve things to the point where my performance is about the same as it was before the most recent patch. I’m unsure if this is a temporary fix or not but I think others should try it and see if they can get some improvement too. (A note when they say resolution I think they mean “window size” and not the “resolution scale” option). Hope it helps others too!

A small update.

Bad news: you have to do this every time you restart the game

Good news: In the first step of the fix, setting both window size and resolution scale to their minimum value (instead of just window size) further increases the fps/performance gain after completing the other steps and now SoA uses max 70ish% of my gpu (a gtx 960 2gb) regardless of the direction I look and runs smoothly at 60fps again at 1080p (which is the best it ever has since shadowlands launch)

Really hope all the information provided leads to a non-temporary fix but for now doing a quick fix every time I start the game makes it run perfectly again. Thank you everyone who assisted with this!

Edit: For clarity these are the steps I did:

  1. Set both your Window size and resolution scale to the lowest value possible.
  2. In advanced settings set your Rendering API to legacy directx11 and then back to directx 12
  3. Set game resolution back to the resolution you normally play at.
4 Likes

Just figured I would add to the post,
|Processor|Intel® Core™ i7-7700HQ CPU @ 2.80GHz 2.81 GHz|
|Installed RAM|16.0 GB (15.9 GB usable)|
GTX 1060 6GB

Edition Windows 10 Home
Version 20H2
Installed on ‎6/‎11/‎2020
OS build 19042.928
Experience Windows Feature Experience Pack 120.2212.551.0

GEFORCE GAME READY DRIVER - WHQL

Driver Version: 466.11 - Release Date: Wed Apr 14, 2021
DX Diag

I usually have my FPS fixed to 60 because of my refresh rate. My graphics quality is left at 7 with particle density set to Ultra because I love weapon enchant looks. Prior to 9.0.5 If I turned off my FPS limit, I could easily have ~100 FPS in the open world with a bunch of addons installed, now I am at 30 FPS (roughly) in the same exact scenario but with a fresh WTF, Cache, GPU Cache, and Interface with no addons. I have messed around with undesirable settings and got it to spike to 56 FPS but that is the best I got. I feel like I am playing on an integrated graphics PC again and it is terrible. I have played this since release in vanilla and this is the first laptop I have used with a dedicated card. I expect better performance than that.

go to system advanced settings within the game, turn off or reduce anything you possibly can. and, for one, set API to DirectX11 Legacy.

sometimes old stuff is better.

Has anyone else with the problem tried the temporary fix I described above?

This bug is still present in 9.1 unfortunately. The temporary fix of lowering the screen resolution to its minimum values then switching between directx 11 legacy to dx 12 and back, then setting the resolution back to normal still works but also still needs to be done every time you restart the game.

The areas being affected are still the same, it seems to be anywhere there are anima conductor streams. Oribos, spires of ascension, and any area where all the covenant anima conductor streams are all activated are still where it is most noticeable for me.

Has any progress been made on this issue? Its frustrating still having to do this every time I log in.

Hello everyone,

I wanted to post an update to this thread before closing it up. Thanks for all of the reports and data that has been shared.

Our WoW and QA teams investigated the reports of FPS drops in Spires of Ascension to determine what was causing this for some systems. The teams were able to confirm what specific art effects were the primary reason for the decreased performance, but unfortunately they were not able to make changes that would help improve the performance while in the dungeon.

What this means is that if you are still only experiencing issues in Spires of Ascension we would recommend tweaking the graphics settings to find out what works best for your system while in the dungeon. Turning down View Distance, Environment Detail, and Ground Clutter should help the most.

2 Likes