Silvershard Mines: The Long Riders Achievement Bug

I reported this bug back in May of last year, apparently to no avail as the bug continues to persist, making this achievement unattainable. I have attempted every possible way of completing this achievement - mounted, on foot, in GW form, but it does not matter how I escort a cart from the spawn point to the capture point without losing control (as the achieve states) , it fails to complete every single time. Is it possibly a Horde specific bug? I have not attempted to complete it as Alliance, but maybe I should try running this as the opposing faction (I actually think I have tried this in SL, now that I think about it, but will try again and update).

I recently attempted this achievement in a RBG group where the opposing group was throwing the match for whatever reason. I asked my group if anyone had this achievement , and anyone who had it completed it YEARS ago. This leads me to believe that this bug is new, well, new as of at least May of last year which is when I first encountered it. I’m willing to bet that if there was a way for a GM to search for completion of this achievement by the population, that nobody has completed this any time recently.

I opened a ticket in-game, and I guess the GM is giving me the run around by linking me to the Bug article on battle.net which just tells me to check wowhead where there’s actually 4 separate instances of people reporting this issue, and to post the issue on the forums where it will probably go unanswered once again, but here I go again in hopes that a GM that actually cares about fixing this will escalate this to the proper dept to test and hotfix this bug.

4 Likes

I opened a ticket on this myself and got this response, below. Apparently others have been getting this achievement recently and I don’t understand how or why. Other than wins, it’s my biggest barrier to getting Khan right now because it isn’t doing what it says:

Hi there Hannhar,

Thanks for your ticket! Game Master Iakinshi here to help with your question about an achievement.

I had a look into this for you now and can see that there are several other similar reports, though no identified issued at the moment.

It’s also been earned by other players recently so it appears to be working at least in some cases.

While we can’t manually verify it or grant missing credit, the best way to pass it on se we can investigate would be via the in-game bug report function.

This has the benefit of automatically collecting and including relevant character data and logs to allow us to address any potential issues as quickly as possible. More info here: https://battle.net/support/article/172958

Thanks again for taking the time to let us know about this, and I hope you can still get credit for it in another attempt!

Best of luck, take care and have a great day!

1 Like

Funny thing is, I got it recently in an RBG. I’m not sure if that’s the variant that’s allowing players to get this, but I could not FOR THE LIFE OF ME get this in a normal BG. I literally tried everything , like i posted, and like I’m sure you have.
I wasn’t even aware that I was in the cart the entire time, we were just fighting for that lava cart to cap the win and boom, I got it shrug

I actually just got it today and I had a theory that maybe it only counts for water and not lava or stone, which I did my previous attempts on.

But I guess the above debunks that.