Is shadowmeld still supposed to take you out of combat, or was it changed? Been trying to use it to get restealths but so far everytime I have used it it leaves me in combat.

Yes, but it depends on what you’re fighting and what’s going on during said fight. I’ll throw in a few examples based on my experiance.

  • If you’re alone and the mob has no true sight, shadowmeld work fine.
  • If the mob has true sight, shadowmeld will only work if you are outside of aggro radius.
  • If you are fighting a boss, you have to be the last person on the bosses aggro table for it to work.

I’m sure there are more scenarios, but this is what I can recall.


Also, keep in mind that Meld doesn’t have the 3-second no-combat time that Vanish has.


Sorry, I should have specified that I am referring to pvp scenarios. For instance, out in the world if being attacked I would hit meld which takes me out of combat, hit prowl and then get a rake stun. Since pre patch, meld works it just isnt taking me out of combat to be able to use prowl and go for that rake stun. Didn’t know if a bug or if this is an intended change

Ya! Yes!! Night Elves getting the nerf bat!

But seriously, I’d say that’s a bug and possibly report it and see what happens

1 Like

Can you confirm you didn’t have any dots on you when this happened?

There are still lots of azerite powers and essences that leave dots on you, even if you aren’t fighting a class with dots.

1 Like

So last night I was doing WPVP on Mech and a feral kept attacking me whenever I got low fighting her betters, and then shadowmelding into flight form to get away when things didn’t go her way.

The night elf cowardice racial is still functioning as intended, and she was dotted up with Moonfire and bleeds each time.

I’ve always been able to do it with dots in the past as long as you do it fast enough and time the dot ticks. But yes, the times I am referring to I did not have dots applied to me.

I will test tonight. That is awful if its true.

1 Like

Still working fine for me. Are you sure you didn’t have any DoTs or fighting against someone who has the ability to see you such as a DH?

I just tested this in a duel. I had moonfire on me and was able to meld, stealth, and apply a stealth rake (stun successfully procced) all between two tics of the moonfire.

I am pretty confident that you either got detected by a truesight mechanic or you still had a dot ticking on you.

Much thanks to Wildbloom - Stormrage for helping test.

1 Like

Any chance you may have accidentally moved in between Shadowmeld --> Prowl. I’ve done it before by mistake >.< and of course you’re within aggro range and therefore are instantly back in combat and unable to enter Prowl

There is an option in the game to turn off auto-attack. You can also add a line that says /stopattack to your macro. This way, if you are still in proximity to the target you don’t just open up with an auto-attack (i.e. melee white hit).

1 Like

Hey listen up here you big cow … sir …

I submitted as bug. I’ve tested several times in bgs, outdoor 1v1s, with dots on me, without dots on me, and it has not worked once. Seems to be running fine for everyone else which is strange. Never had this issue occur before 9.0

It isn’t working for me either.

Ok, could it be any of these situations? If not then it’s probably a bug of some sort.
I can confirm that it DOES work, at least in pvp.

Are you guys just clicking the ability, or is it macroed in some way? Like, to an ability that would break stealth?
Are you in an area where stealth would be detected, or by an enemy with detection?
Are you using this near a demon-hunter?
Are you using it where an AOE ability would hit you?
Do you have a debuff that causes damage; Disease, poison, etc?

Maybe you were aggroed by something that reaggroed right away, like say you Meld and then just as it goes off some azerite thing procs and damages the target? I know I’ve had something similar happen with the minor power of Nullification Dynamo essence going off and breaking my stealth.

I’ve tested it to the point where in a duel I would get into combat out of stealth, shadowmeld and it will not take me out of combat to be able to prowl. I’ve tested in world pvp instances where I’ll run up on an enemy player out of stealth just hit them with shred and immediately attempt to shadowmeld to prowl but it will not take me out of combat.

I do not use a macro, everything is keybinded to separate keys which I hit meld, prowl and then rake. As I have stated before in previous posts from days ago, this has worked perfect for the entirety of Bfa and previous expacs.

I did submit it as a bug but haven’t had much time to see if it’s resolved, hopefully this weekend I’ll be able to check it out further, I hope it’s corrected.

Thank you, was worried lol

You can just press shadowmeld > rake stun you dont need to hit prowl. Seems to be working for me fine