Sept 8th-12th 2019 - WoW connection issues / WOW51900328

Linux user here. My gf on the same wifi network was able to log in fine all day, even with the DDoS attack. I switched DNS servers, MAC addresses, even used the same UTP cable from her desktop, to no avail (always stuck on “logging in to game server” and then disconnected with WOW51900328)). However, i am perfectly fine to log in using her computer (Windows 7). Reinstalled bnet using Lutris, reused the same wow installation, same results. I even tried tethering from my phone’s 4G, still nothing.

Tried to install wow on another location but it throws an error every time I try to. I’d hate to think Linux users are getting fingerprinted for no reason and denied logging in (bnet app connectivity itself works fine btw).

I know you guys dont support Linux, not asking you to. We usually manage on our own to get the game to run and play normally (and btw, it had been so for more than a year until today). Certainly something changed today that is outside our control.


Yup, Lutris/Wine – Arch

Server - Westfall
Error Code - WOW51900328
ISP - Comcast

If this is a Linux targeted issue I’ll just dump my sub and forget blizzard all together. For a decade I’m been playing wow on wine and when minor issues crop up I know its on me to fix it (unsupported setup and all, I dont mind solving issues). But this is just to much, you know most of us work and only have weekends to play? So far … very unimpressed.

Was on the server configing addons at 7pm EST…at 930… nope.


And still no blue text.

1 Like

I think we have to wait till tomorrow when they get back to work for a response.

Same thing here. Pop OS and Lutris can’t get on after getting kicked about 1 P.M. Central today. Finally was able to get back on with windows about 5 P.M. Central. Now I can’t get into the game on either platform. I am getting the same WOW error that everyone else is getting. I am on Myrsereal If I can’t play on my Linux machine I will end up cancelling. It would also be nice if everyone was compensated for the inconvenience this weekend.


Go to their twitter page seems like there is an ongoing DDoS attack still,

Yes, we know, this is the point of this whole thread.

Sorry that came out rude.
Tilted a little bit over here.

Considering there is a 4 hour time difference between tweets I say that I might be better off going to bed and see if they have fixed it tomorrow…or not.

Lol, I feel you, too bad I can’t play my Warrior right now, I’ve got a full bar of rage :wink:

1 Like

Did u compensate for server down last time? Will u compensate for the issue?

Thanks for the new reports.

We are still working on getting everyone back into the game. We are still investigating the situation. If we have any updates we will let you know.

Please continue to provide realms and exact errors if you have not yet done so.


At least Diablo 3 is not effected.

was WOW51900328 now WOW51900319

retail Server - Alleria Classic server - Pagle
ISP - Suddenlink

I feel sorry for diablo fans… i loved the series

My name - Remulos

I made a thread for Linux-specific problems: Linux users unable to log in, WOW51900328/329 error after logging in so it would get more attention by anyone who just came here.


Also a Linux user that can’t get past server select.

Character name: Zigz
Realm: Stalagg


Gregoran - Bloodsail Buccaneers

Astrazula - Bloodsail Buccaneers

error WOW51900328

1 Like

Can’t get past server select, Windows 10.

Realm: Stalagg
Error: WOW51900328