Screen flickers, goes black, green textures everywhere!

Okay so in all my years of playing WoW I have never experienced an issue like this before. Randomly when playing, my game screen will flicker lightning fast, textures won’t load (shades of neon green, red, or blue), or the screen just goes black and I cannot see what’s happening. And the weird thing is- it only happens in retail, not classic. It gets so bad I have to exit WoW to get it to stop. Sometimes that works and sometimes it doesn’t.

I would be pretty surprised if it were my computer specs causing the issue. 2013 iMac, 16gb ram, 3TB, decent graphics card. I don’t even run the game at ultra graphics (like recommended 4 or something pretty low), and my frames run at a pretty consistent 60fps.

Yes, I have tried restarting WoW. Yes, I have tried restarting my computer. And yes, I have tried deleting the cache folder. None work so far. No, I have not tried reinstalling WoW. Please don’t make me :slight_smile: …T.T

Can try and provide links to pics to demonstrate what’s going on if that will help. Any and all help appreciated. Thanks so much!

That sounds like a graphics card issue. You may get more knowledgeable help faster in the mac tech support forum.

I suppose it’s always possible. But I have never had an issue playing WoW before with this particular computer. I have even pushed the graphics near ultra and everything loads just fine. Laggy, but not the flickering or weird textures, so not sure why something would change now?

We do see graphics cards go bad, things overheat, memory on cards can go bad, power supplies start to go and don’t provide the right amount of power, drivers can change how things are addressed, os updates…
It’s not really unusual to see this, which is generally considered artifacting. Again, the folks in the mac tech support forum may know more about if this is common or uncommon with macs, or your flavor of imac.

I have posted in the Mac tech support forums, but will post my specs to you as well if that will help.

iMac 27" (Late 2012)
OS Mojave 10.14.6
Processor 3.4 GHz Intel Core i7
Memory 16GB 1600 MHz DDR3
Graphics NVIDIA GeForce GTX 680MX 2 GB

So I guess late 2012, my bad. Also realized this iMac is still capable of upgrading to Catalina which is currently installing. I have it set to automatically update the software so not sure why that didn’t happen- also my bad. Maybe upgrading to Catalina may help? Not sure if that would really effect the graphics card use/drivers or not.

Moved this over to the Mac Technical Support forums. It sounds a bit like the graphics card might be part of the problem, the graphics card isn’t listed on the supported video cards list. Have you tried running an Apple Diagnostics scan to check for possible hardware issues?

If this is caused by driver issues, Nvidia graphics drivers haven’t been updated in some time for MacOS systems in Mojave and Catalina, so updating to Catalina may not resolve the situation. Due to these concerns and issues with the video card, you may need to contact Apple support if the problem continues.

I attempted to run a Diagnostics Scan over the past two days. I could not get it to run successfully, so that in itself is a problem now. I continually get an error message saying:

Error: 0x8000000000000003, Cannot Load ‘EFI/Drivers/TestSupport.efi’
Status: 0x00000003

Looks like I might have to take this guy into the Apple store. I had no idea there were any internal issues with this computer. It has only acted up when playing WoW recently. But being 8 years old at this point, I think that warrants some servicing and a tune up for sure.

I’m sorry to hear of the issues with the Apple Diagnostic scan, Eldergoose. I definitely agree that this needs to be looked into by Apple support since the scans are failing, it does indicate some issues with something on the system either with the scan, MacOS, or the hardware on the system may be giving up after some time. Hopefully, it’s something simple that can be addressed!

Could it be this known issue, or related to it somehow? Known Technical Support Issues - Updated July 21, 2020 - #16 by Caterpepi

A player posted imgur links to some screenshots of their issue in this thread, [Main Thread] Nvidia - Texture Flicker. Possibly caused by MSAA - #11 by Promenthas-ragnaros

I was thinking the same thing, Clayre, but the Nvidia drivers are a bit different for the MacOS computers that it seemed less likely to the MSAA texture issue. The description is also a bit different from what we’ve been seeing. The problem is a specific driver problem with Nvidia cards from our findings.

This looks similar to my problem, but some of my flickering/texture issues are more magnified than those pictures. I’m also not sure if it is the same problem, but caused by something different because I am using a Mac. Looking into taking my desktop to Apple to see if they can take a look at it.


It can be difficult to screen capture the issues at their worst. Trust me, I spent a fair amount of time flying “blind” yesterday because the screen was literally tearing all over the place (ie. mostly black).

For me, I just switch the first setting in the advanced setting from enabled to disabled and the problem is fixed. Fixed in that it forces the game to reload the graphics driver because the setting change requires it to do so. Same affect as telling it to autodetect your card or specifically choosing a card. Almost all of the advanced settings will force a graphics driver reload.

It is 100% a graphics driver issue. But alas, your system will NEVER see an update because it is officially on the EOL list from Apple.

So your fix will always be to do exactly what you have been to make the problem go away.