Scarab Brooch not working as intended

I can confirm that Patriot is correct, made my own video as more evidence (No I do not click off any of the buffs). I also tested with the exact same rank of HT and any crits I got would remove the buffs that were not from crits, this is not a mechanic you can really play around and should be fixed.

gfycat com/masculinelawfuleagle

1 Like

I think this also explains some of the wonky behavior I am seeing particularly when aoe healing. Crits occur on an individual basis with an aoe cast, so maybe on a prayer of heal 2/5 of party members get crit, since not everyone is getting healed for equal amounts that “larger shield priority” thing kicks in and causes havoc.

Hopefully this bug gets some attention asap as it is truly make or break from a pretty important piece of gear in AQ.

3 Likes

This is correct, here is a video of me testing with Prayer of Healing.

You’ll note it does not put a bubble on anyone in the entire party except me on the second cast.

dropboxDOTCOM/s/mdk6gp6o0xjafe3/Adjective%20-%20Herod%20-%20Scarab%20Brooch%20.bug.%20test%20%28POH%29%209.10.20.mp4?dl=0

2 Likes

Prayer of Healing can also bug in the way where it applies the shield to yourself and then the entire party, but when the party gets the buff, it disappears from the caster right away.

If the heal that hits the Priest is higher than every other target, they won’t get shielded. But if the heals that hit others are higher (critical hits, coefficient variance), the priest loses the shield. Due to the way the effects are applied sequentially, sometimes this results in nobody having the shield at all.

2 Likes

I was also able to duplicate this behavior. Smaller shields on yourself are being removed by producing larger shields on other targets. This also causes a lot of issues with Prayer of Healing.

2 Likes

Thanks all for providing the documentation. Have we had an official response from the dev team?

2 Likes

Haven’t seen any updates on it yet. I haven’t opened an in-game ticket though, assumed reporting here should suffice. Hopefully they’ll acknowledge/fix this one though because it really renders the trinket pretty useless. I’ve tried raid healing some of the more damage intensive fights (huhuran/viscidus) using it, and its incredibly painful watching shields get knocked off myself and other targets before the aoe goes out. I am going to have to use another trinket combination until this gets resolved, there’s far too much RNG with this broken mechanic to make it reliable.

3 Likes

On top of all the aforementioned bugs, using “The Burrower’s Shell” in tandem with Scarab Brooch also prevents the “Persistent Shield” effect from being applied.

1 Like

trying this on retail and it acts correctly on there, it only refreshes the shield if the heal is more than the previous, definitely broken for aoe spells in classic wow, on retail it doesn’t refresh at all until you heal for more than the previous shield amount, this means if anyone has hit a higher heal on someone their shield will remain until a higher heal has hit them.

you can see it stayed on you when you hit yourself last with the larger heal, so its partially working just not correctly with the aoe heal as each target hit should be treated as a seperate spell but currently its treating all targets hit as one spell so only the person that is healed the most gets the shield.

1 Like

Update from an in-game ticket I opened:

Your ticket has received the following response:

Hey there Mareg!

I had a chance to read over your ticket and I understand that the Scarab Brooch is not working correctly. I’ll be happy to take a look into this for you today.

I had a look into this for you and found a number of similar reports. Our developers have confirmed that this is something they are working on fixing, but so far we do not have an ETA for the fix.

Unfortunately we don’t have a workaround available at this time but we are hoping to have a fix very soon. We will be sure to keep players updated about this in future patch notes so keep an eye out!

For more information about how to report bugs for our games, check out this link:
https://battle.net/support/article/15043

I’m sorry for the trouble caused, but this information should help us to get the bug squashed! Be sure to let us know if you need anything else as I absolutely want to make sure you get fully taken care of here. Thanks so much again for contacting us, and I wish you the best going forward!

Click here to review and resolve your ticket. If you continue to experience issues, you can respond to your ticket with additional information.

If you do not resolve the ticket or provide an additional response within one week, we will resolve the ticket automatically and you’ll receive a final update via email.

Regards,
Blizzard Support

So looks like they are maybe actually working on it?

9 Likes

Thank you Mareg - you the real MVP!

2 Likes

They will spend resources fixing improved weapons totem talent bugs, but it’s unlikely anyone will get a response from Blizzard about this. Smh

1 Like

they still haven’t fixed imp weap totems though lol

1 Like

Sounds like they’ve at least addressed the totem one now. Still no word back on the brooch though. By the time they fix this AQ will be over for most. Hopefully they can fix on time for naxx as it might serve a purpose there…

1 Like

seems to be happening with Chain Heal as well according to shaman discord.

Hi All,

Just wanted to pop in and let everyone know that the fix for this issue is present on the 1.13.6 PTR now and I’ve gone ahead and updated the PTR patch notes thread here with this information.

Similar to the issue with Improved Weapon Totems, this trinket did behave in this incorrect way throughout the entirety of its availability during original World of Warcraft. Much like the totem issue, this was not intended and the issue was fixed in later versions of the game. As a result, we are making a fix to bring this item in line with its original intent.

Thanks for the reports about this!

9 Likes

Could you look into Darkmoon Card: Blue Dragon? It doesn’t proc on dispels, cleanses, cures, and decurses.

2 Likes

as well as Hots. but the dispel aspect is just silly.
please PUUUUHLEASE FIX DMF BLUE DRAGON

Thank you Aggrend!!!

Another Trinket thats not working properly and should be checked at Arcanite Dragonling completely bugged *please fix this blizzard*