Savagemane raptors neutral and unattackable


#1

WQ Ravoracious up. Quest mobs are neutral and un-attackable.


(Dokkslfar) #2

Same here also a void elf, I suspect its the same as the previous bug with the beastmasters where the mobs were un attackable to allied races


(Dokkslfar) #3

Still Bugged today for invasion WQ spell compontents, the mobs were all invalid target for allied races


(Hasylla) #4

This is currently bugged for my void elf as well. Camping out and leaving the area and returning did nothing to help.


#5

New set of invasion WQs, same bug persists. Allied Races are still unable to do this quest, save for attacking Queenfeather.

This of course keeps those Void Ravasaurs on you for the next part, the stealth quest in Warbeast Kraal…where they don’t stealth and thus make the quest undoable as well.


(Rootluid) #6

Same here on my Void elf mage. Both days that assault quest was up I was unable to attack the raptors. Its only the first patch of the beta but still, they should have fixed this by now.

For any allied races who cant attack those raptors, if you go further into the zone by where Ji’ark spawns there are Direhorns that you can kill to complete the quest as well. It will save you time from just camping that 1 rare mob.


#7

Hey, still not fixed, and now the Direhorns don’t seem to give the quest item any more. Please fix.


#8

I’m experiencing this right now. I was wondering why I couldn’t attack them. Now I see that it’s an Allied Race bug. Sad times as I am a Void Elf Shadow Priest. :frowning:


#9

Literally still not fixed and no blue post, this is ridiculous.


#10

Yep, reported this last time we had Zuldazar as the invasion point. Still nothing done to fix it or even acknowledge it from blizzard.


(Artemisia) #11

Still not fixed and completely bugged on my void elf. Fix this trash already.


#12

Confirmed still not resolved as of 12-29-18.

Blizzard, can we get a confirm you guys are aware of these quest mobs not being attack-able by allied races and an ETA on a fix please?


(Volley) #13

Bug still not fixed. Submitted in-game bug report as well.


#14

Bugged on my void mage. More annoyed with this grade a customer service with not even a reply aa to why it is still bugged, let alone just fixing it…


#15

have this quest up today for my void elf Warrior and not able to attack anything but Queenfeather. this is a really horrible experience to be on a quest for 45 minutes just to collect 12 stomach lining. Some sort of acknowledgement this is being looked at would be nice. esp since it seems to be a similar bug to a previous quest so should be an easy fix.


(Dokkslfar) #16

Still bugged out 18 days later


#17

21 Days, still bugged.


(Hasylla) #18

I also love how, if you talk to Magister Umbric, you get saddled with two void pets that will follow you into the stealth mission. They aggro mobs and make it oh so much more frustrating to complete. So Spell Components is not doable and you get punished for checking to see if they actually fixed a bug.


#19

Still buged in my Hunter Void Elf!