Rep Achievement Tracker broken? 16/90 exalted

I currently have 86 exalted reputations. I have the 80 exalted rep achievement to prove this.

However… on the 90 exalted reputation achievement, I am showing 16/90 on the character that has 86.

I have renamed my WTF, interface, and any other folder. That didn’t fix it. Does anyone have any idea what I can do? I worked my butt off to get those achievements.

Any luck with this? I am in a similar situation. Currently 19/90 although I have 86 as well.

Nope. Haven’t seen a single blue talk about this issue.

Ask in Customer Support. The Bug Report forum is one-way, and no blue will ever respond here unless it’s QA asking for more information.

This bug is nice and clear, so there’ll be no blue text here.

GM Shalalishul
Hello BlewYou,

I hope besides the issue you’re having a good day so far. I am Game Master Shala, I am here to help with your issue the best way possible.

I am sorry to see that you are not getting credit for the achievement. As a player myself, I know this can be frustrating. I did some digging here to see what we could do to resolve the issue. I checked here, and there are currently no confirmed bugs with the Exalted Reputation achievements. When reviewing an achievement, make sure to confirm you have not already reached exalted with the faction you are tracking on another character. With these achievements being account wide, you may have received the credit for the achievement on another character. For more Information on the recent changes to reputations visit the link below.

While I realize this is not the ideal resolution you may have been hoping for. I appreciate taking the time to get in contact with us about this. We truly appreciate your time, patience, and understanding.

This is the ticket response that I get every time I submit a ticket for it. They deny that its a issue and “All is working as intended”. I have submited a PDF/Screenshots of all the exalted reps I have on my toons they don’t look at it and tell me “All is working as intended but I submitted it to our Bug Report Department you should too”. This was 1 month ago, and still the same.

That is exactly the reply I get. I am pretty sure I just hit 90/90 today as well, and it’s only registering as 20/90.

This is getting really annoying.

i send them a PDF file showing them out of all 100 reps which ones I have, they verified it and said its correct, but they can’t “interfer” and must wait for Bug Report department to fix it… Its literally been 1 month since this point. Now when I kept pushing saying I’m tired of paying for a game that isn’t working. After 1 months its BS… They responded “If you continue to harass support team because our answer will not change but we can take further actions up to and including account termination”
So since paying customers want the game to work the right way, the way we pay for. The reason I play isn’t to be some uber super raider… I m+ when I want but I do it for achievements, 1st they told me it was another faction even though that doesn’t make a difference since its account wide. SO I paid $30 for Faction Change. Now they dont know and leave it to another department. So you got me to pay $30 for a faction change and it wasn’t the issue… NICE more money for me spending and nothing was resolved and of coarse you won’t refund… Don’t push to hard otherwise they threaten to close your account.

I’m getting the same thing. It says 21/70 but i know i’m close if not to 70 reps. I have the achievement for 60 reps already. I put in a ticket and they say they cant interfere or change reps/achievements and the best thing i can do is put in a bug report.

Similar problem here.

Got the 60 Exalted Reputations achievement during Legion.

Currently have 71 exalted reputations on a single character (not including guild and “best friend” factions). 70 Exalted Reputations achievement tracker says I have 22/70.

I don’t grind reputations on any alts, and this has been my main since MoP. (Have not gotten exalted with any faction on any alt since getting 60 Exalted Reputations on my main.)

Sure seems like a bug.

I count 69 eligible Exalted reps on your armory page. A few that you may have included do not count either for being meta-reps or deprecated reps, even though they have a bar in the UI.

I agree the achievement UI tracker seems to be a bit off lately (on mounts and toys too, the other main “counted” stats), but the achievement should still ding when you get your next eligible rep to Exalted.

The good news is since you have almost all the current reps at Revered you can easily knock it out, rep is so much easier to grind nowadays.

Which exalted reps do I have that are not eligible?

The text of the achievement does not indicate only particular kinds of factions are eligible, and I’ve never heard this before.

Edit: Just checked WoWHead; chart there claims that guild counts. If so, then I have 72.

When looking at Wowhead you have to remember its not Exalted on 1 character they are now account wide. So like me my paly has like 40 exalted, and my druid has 55 Exalted so I should have the 90 Exalted Achievement. The tracker is DEFINITELY broke, but they are doing nothing to fix it. I have complained about this for the last 1 yr at least and its still not fixed because it’s not a priority for them. They come up with every excuse, then when they are out of excuses they say “Bug Department has to fix it sorry we can’t do anything about it wait for them”. Its been in Bug Department for a year and nothing yet, this is unacceptable.

Got confirmation from a GM today in my ticket response that this is a “wide-spread” bug. S/he didn’t actually confirm that the dev team is working on it, but said that it must be resolved by the dev team.

I’ve been putting in tickets for the last year complaining about this achievement being broke, for last year they have been telling me “There are no known issue’s its working as intended” glad to know it takes a years time of tickets and them threatening to terminate my account for them to now admit there is a issue.

This is an achievement I have been working on since day 1. Specifically this one.

Would be really nice if they could respond, at least tell us this is in their to do list.

Same issue. I regularly submit bug reports with the same info pasted. It looks like I should have 93, but am not even getting the 80 achievement - reads 23/80, with the 70 one earned over three years ago. All reputations obtained by a single character over the past nine years.

It is showing 14 out of 50 for myself and i already have the 45 rep achievement. My recent ticket had a reapos e that said this most likely a bug and they thanked me for the info…

Yeah I’m having this issue. I just got exalted with The Sunreavers today and should be 99/100 but It still says 98/100. I even relogged to see if it would change, nope.

I’m pretty sure I should have earned the 80 Reps achievement by now, since I think there’s maybe 12 obtainable reps left to go, but heck if I know. My counter is stuck around 16/100 even with all the achievements to prove otherwise.

I’ve sent in multiple tickets and gotten varied answers. One GM said that the counter may be wrong but that ‘internal devices’ were tracking the achievement correctly, and it would be rightfully earned when you got there. I’m not sure if I believe that though, since there’s no way I have 21+ reps left.

It’s very aggravating and I feel this should be a priority bug fix. Getting nearly a hundred exalted reps is no easy task-- something that’s been 7 expansions in the making and lord help you if you skipped a removed rep grind. There’s nothing players can do to get around it either, we’re all at the mercy of whatever number decides to erroneously display.

1 Like

I don’t think this info is correct. I have 82 exalted reps on this character, and I don’t have either the 70 reps achievement or the 80 reps achievement.

I might have missed it, but I did not see a fix in the 8.3 patch notes.