Renewing Mists broke?

Renewing Mists not working. After todays patch, is simply broken. It appears to cost mana and proc Gust of Mist but simply doesn’t leave the HoT effect nor do any healing?

Tried talenting out of it and back into and various other things to no avail.

Anyone else experiencing this? Am I losing my mind?


Yea it’s not working for me either… I literally lost a key bcuz of this LMAO

freaking indie game


Luckily I was just in a leveling dungeon so it wasn’t a big deal.

At first I thought it was just a display/interface issue but after checking the combat log and doing some other testing I can say that it is simply just not working at all.

1 Like

it only stops working for me if the new talents are chosen

It still doesnt work

mine doesnt work even with my same old talents. didnt change anything

Mine just broke too…

Nope, is not working. Something is obviously still busted despite the extended maintenance.

1 Like

Lol this is kind of funny though.

yea mines not working. I mean this patch has been out all day right? How has this not been hotfixed? Seriously it’s a pretty big issue. What are these people at Blizzard doing.

2 points of Overflowing Mist or Resplendent Mist IS WHATS CAUSING THIS BUG!
Try using only 1 point into Overflowing Mist !

My Mistweaver is only level 18 and is just barely able to talent into Renewing Mist and its not working.

Something is fundamentally broken with the spec at the moment, I don’t think it has to do with talent selection.

Small indie dev

1 Like

Yes more may be broken but currently you can test with those talents and it works with 1 point into overflowing mist not with 2 points. Its a start so lets hope the devs can figure this out fast

It’s working for me. I don’t know what I’m doing different.

1 Like

also works for me, though I’ve only done a raid today.

1 Like

Thank goodness it’s not just me…

I logged in, queued for Solo shuffle right away and noticed that rewnewing mist wasn’t working as soon as the gates opened and I tried to HoT my DPS. So six rounds of arena with no renewing mist on a mistweaver…

Went 4-2 thankfully and said that’s enough until this is fixed.

1 Like

put 1 point in rapid diffusion

Im only level 18 lol.

Regardless, it started working again for me just now when I logged back in.