Recrafting Bug?

Hi, I am trying to recraft an item for engineering googles and I have the mats and I am at the tinker station but every time I press recraft it doesn’t do anything. The cast bar fills up, but nothing happens. Anyone know what’s going on?


I can’t either, trying to recraft a LW chest. nothing happens

We currently have a bug were recrafting doesn’t work if you attempt to recraft a piece that is not at max durability.

Fortunately, reagents aren’t consumed or anything like that. It just quietly fails.

We’re working on a hotfix for this.


This might be related?

When I try to recraft, it says missing reageants, though I have them in my bag

Mine is at max durability but still fails. Trying to recraft the Trailblazer’s Scale Vest I just made to change stats.

EDIT: turned on my error messages, says I’m missing Artisan’s Mettle though I have 103 in my bag.

If you have the quest called Artisan Supply where you have to deliver an item, either complete or abandon that & it should work


Just found that out, thank you

1 Like

Thank you :slight_smile:

1 Like

when i looked at engineering helmet to recraft ilvl stays the same and stats stay the same so I didn’t recraft.

Wish I knew about this post some hours ago before I used a matrix on another band which brings my haste down by 2%, but I suspect Mythic+ gear and enchants will help with my issues hastily
I’ll see myself out! XD

had that quest in log,fixed problem with it unable to find artisans mettle

This is not the case for me. I’m trying to recraft a necklace to add Blue Silken Lining. The recraft occurs as expected (quality even goes up) but the blue silken lining just returns to my bag.

Same here. Wasted my mats.

Durability didn’t have anything to do with it.

Had a JC recraft my Torc of Passed time, lost all mats, neck upgraded to 392 from 386, but lost its embelishment. (Back in my bag)

Please fix… its not cheap crafted these things.

Hi not sure if this is helpful but my husband was having the same issue trying to recraft some blacksmithing gear.

Through some google searches we found that pieces needed to be fully repaired, tried that and the error persisted.

I suggested he remove the gear from his character and try recrafting from his bags, and that worked!! Hope this helps someone, there really should be error messages letting you know the problem.


Yes ty, recrafting necklace in bags removed the issue. Cheers!