Random FPS drop since 9.1

Hello all,

If I can provide any supplemental data, please let me know.

I have a Acer Predator Helios Laptop(i7 7700, 16GB Ram, Nvidia GTX 1060), and prior to 9.1, I had no issues with FPS in anything(solid 60, running either a 6/7 in the graphics settings).

Since 9.1, I am hit with random FPS drops all the time, M+ and Raid particularly. I have disabled all addons, reinstalled wow, turned the graphics settings down to 1, and even reformatted(long time coming anyway!). Still seeing the FPS drop today(in particular, nothing until I ran a M+ right before the second boss in Sanguine). It hits for like 2-3 seconds(drop to like 10 FPS), then pops back to 60.

I seem to have ruled out addons, install, Windows, etc. Is my laptop just not cut to run WoW Smoothly? Just seems odd I never had this prior to 9.1.

Thanks for the help in advance!


Please include the diagnostic needed.

If you had the same issue (3060 9600k 32 gb) I did with FPS drops what I did that seem to have worked: reset UI, DDU then installed new driver, unlocked power limit in intel zboard bios, cleared data in the launcher - option to reset in settings (in addition to renaming the usual folders cache, wtf, and interface). If that works for a fix then great. I also turned Vsync off, lowered AA, rt off (10 series should have it off) etc Have a 1060 rig 16 gb spare rig and think the same process should work. Uncheck lock cursor. GL with fix.