Random DC over past few weeks

Hi, I have been having an issue with just random dcs over the past few weeks. I have tried deleting all my add ons, resetting my ui, replacing computer, but for a different reason. Reinstalled wow on new computer. I dont disconnect from discord or anything else. I ran an MTR these are the results I got. Is there any information you might be able to give to help me out. Thank you

    Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|
| Home - 9 | 894 | 820 | 0 | 0 | 32 | 0 |
| 69.58.144.1 - 0 | 1524 | 1524 | 1 | 3 | 64 | 2 |
| fttp-209-182-240-8.becfiber. - 0 | 1524 | 1524 | 1 | 3 | 83 | 2 |
| fttp-209-182-240-39.becfiber.- 0 | 1524 | 1524 | 2 | 4 | 83 | 3 |
| hu-0-1-0-2-3714.dfw1.networklubbock. - 0 | 1524 | 1524 | 14 | 16 | 77 | 15 |
| eqix-da1.blizzard. - 1 | 1516 | 1515 | 14 | 19 | 105 | 15 |
| ae1-br01-eqda6.as57976. - 0 | 1524 | 1524 | 34 | 41 | 740 | 37 |
| No response from host - 100 | 156 | 0 | 0 | 0 | 0 | 0 |
| 137.221.69.81 - 0 | 1525 | 1525 | 34 | 36 | 108 | 35 |
| 24.105.62.129 - 0 | 1525 | 1525 | 34 | 36 | 93 | 35 |
|____________||||||

I don’t see any disconnections in your network test. Did it happen while you ran it?

Yes i had a disconnect occur while running

Unfortunately, it’s not showing in the test so I can’t point to what’s causing it. You mentioned changing UIs and even computers, so perhaps a firewall is triggering a disconnect from the game.