Quest bug: Demonic Improvements

Quest : Demonic Improvements
Stage : 0 / 1 Class hall upgrade chosen
Bug : quest does not progress after choosing upgrade and Accept button clicked

Character Level 28

Wow build : 9.2.0
Windows 10

not working for me either.
is this even retail anymore

Not working for me either :confused:

Not working for me either, glad I’m not the only one, any fix yet?

I haven’t had this issue as I haven’t played my DH, but people in Newcomer Chat are experiencing this. They don’t use addons, they’ve tried reloading, etc.

I have a fix, download the wow app and select research, then select something and click accept. It will then begin researching.

I don’t know why this works but I’m going to login to confirm


Wow that worked, thank you!

1 Like

This worked for me too. Logged in using the WoW companion app on phone, brought up dh that was having the issue, switched to Legion expansion, chose an option to research and it is researching. Thank you friendly Worgen!

1 Like

This worked, thank you.

Why on earth would players need an app to play if they don’t use apps? I don’t even use my phone for this game, and definitely do not have any apps installed.

The way this is written implies a phone app, but I suspect its something else? Correct me if I’m wrong but why on earth would a player need a phone app to play wow when they don’t use their phone for wow?

might anyone know a way to complete this quest without using the companion app? i am playing on a trial account and can’t link the app to it (i tried). am running no addons and have cleared the cache/wtf/interface folders

As a follow up to my last post; activating Chromie Time (i set it to pandaria) and then going back to the class hall allowed me to accept the upgrade and continue the quests.

1 Like

It’s a workaround for a bug, I’m not saying the bilz programmers intended you to use your phone(that’s ridiculous). I had encountered a bug, that is simply how I got around the issue.

I don’t use my phone for the game at all.