PTR install size?


(Levíathan) #8

(Just quoting you so that you it alerts you)

So as far as the public goes, the data sharing installation is not live yet. The support agent that tested it for me is using an internal installer that we don’t have yet, hence why it worked for them, but not me/us.

So to summarize the current setup (same as I posted above):

Currently the system is creating a completely separate install (like it used to) so there can be a storage issue.

However, it is copying the duplicate data from the live game over, thus 1) reducing the download size to very little, and 2) installing much faster.


#9

Can confirm it is copying the data from live first. (54.74 gigs of copied data) So I assume we’re just downloading the patched in data.


(Levíathan) #10

Indeed!

So far, we’re only saving download time/size.


(Svenska) #11

Which was a relief because 50+ gigs is a two day install.


(Olak) #12

18 hours for me, but only because my brother-in-law kept checking on it while I was at work.


#14

We’re actually testing some new improvements that allow the client to share the majority of game data between installs, so you don’t need multiple copies of the entire game in order to test things on PTR.

To use this, you’ll need to be using the Beta version of the Battle.net app (Click the Blizzard logo in the upper left -> Settings -> Beta -> “Switch to Beta”). Then, when you install the PTR, it’ll only need to download about 2.5gb of data. Note that if you have the PTR already installed, you’ll need to uninstall and reinstall it to use this new tech.

Once it’s installed correctly, you’ll see a new folder called “_ptr_” under your World of Warcraft folder, which should be MUCH smaller than a completely separate install.


How do you install PTR?
So, you wanna try the PTR but
#15

Might actually do more ptr testing with this… filling up 90+ gb of SSD space with wow stuff was a little extreme.


#16

That was quick and easy. 2.5gb download, few minutes.

Uh, using this beta install with shared data – can’t make Zanda/KT character. So i guess thats the trade off for not downloading 50gb of PTR?


#17

Did you have to install it inside the original World of Warcraft Folder? I followed the steps listed by Lore and it wanted to reinstall the whole game.

Edit: Fixed it myself. Make sure when you choose your destination path that you verify within the UI that you want to download it to a folder that “shares” data.


#18

This is fantastic. I’ve been hoping an incremental build like this forever. Thank you Blizzard devs!


#19

Aside from still having the no realms available issue, the install did work as mentioned. Much better!


(Growltiger) #20

Ah, Beta Battle.net is the key, thank you!

Does the new code also have an option to clean out old cruft from the data files? I guess you can continue doing it by deleting one (e.g. ptr), then re-installing it non-shared, then deleting the other version and re-installing it shared, but it should be able to do it much more efficiently, as well as not needing nearly as much temporary space.


(Growltiger) #21

Well, that was weird. I tried to do the install with the Beta app, and at first it said there wasn’t enough room, it needed 56GB or whatever. Then I did “some things” (e.g. seeing if I could select a different folder, see how much it said, etc), then all of a sudden it said I only needed 2.6GB and let me install.

Perhaps it should wait until it’s scanned the existing installation and discovered the actual amount of space needed before saying it can’t install - say “scanning to determine space required” or something once it determines there’s already a version installed at the currently selected folder.


#22

Is this feature not available to everyone? I followed the blue post but in the beta tab of battlenet app settings, it says “There aren’t any beta features to test right now”. I tried various things to “trick” the battlenet to write PTR and retail to the same folder, but it keeps saying that version isn’t correct for that folder, or something along those lines. I don’t know where battlenet stores its settings otherwise I would modify those instead.

In either case, I dont have this ‘beta’ option. Does anyone have a link to the beta version of battlenet?


(Growltiger) #23

I just clicked the Beta button under Preferences, had no problems. I don’t think there’s a separate download for the Beta version, you have to update through the regular version.


#24

May be they forgot to give you BNA Beta access. As far I know it requires special battle.net license.


#25

i have the same problem


(Unian) #26

I did all this but it’s still telling me it requires 52 GB of disk space. :frowning:


(Sorelai) #28

It would have served your customer base better to have posted this in a stuck topic when the new PTR was made available.

Maybe as a secondary heading in: 8.1.5 PTR Developers’ Notes


#29

Any chance you could make an effort to post this kind of information in it’s own dedicated sticky, before people ask about it?

Saves a lot of time and makes things clear.