Object and architecture flickering: possible fix inside


#1

Hello. I’m experiencing significant rapid flickering of architecture and objects. Morphed terrain such as hills, mountains, and sea floor aren’t affected but most everything else is to some degree. It happens as I move my view around, either in first or third person. Switching to DX11 had no effect.

Edit: try this fix, it worked for me


PTR Terrain Glitching
Flickering Area, and "Stanley"
#2

also having the same issue, this is a fresh install of the ptr with no addons


#3

As is mine. Video card is a GeForce GTX 1050 Ti using driver version 417.35


(Zidko) #4

Same for me on Benedictus ptr server. GTX 750 Ti 417.35


#5

I’ve gone into the in game settings menu and reduced/turned off everything to minimum that I could find under the graphics and advanced tabs. Flickering still happens.

Edit: if I’m inside The Great Seal, the flickering stops. As soon as I take an elevator or step outside to Dazar’alor, the flickering kicks in.


#6

I had the same issue. Inside buildings everything was fine but I had to log out because the flicker was giving me a headache


(Albricksen) #7

The object flickering is also causing massive lag and constant disconnects. It’s very annoying.


#8

Same issue here.

Nothing has helped to fix it yet. :frowning:


(Wolftrakker) #9

GTX 1070 founders 4 gb
No addons, fresh install. Only place it didn’t flicker was in the instanced SW portal room.


#10

try turning on Vsync, that seems to help for me with flickering


#11

Don’t think that is the type of flickering being talked about here. In game objects are just randomly disappearing when you move your camera around so you have no idea where walls are. Makes navigating the world pretty tough.


(Josefine) #12

Vsync may (or may not) help. I haven’t been able to log in long enough to do much of anything, but it sounds similar to a problem that happened in a previous build.

What happened before is the post effects and render passes were going out of sync in some cases, which meant effects were being applied to the wrong (or just empty) zbuffer frames. This led to things going invisible, flickering, zfighting, and weird ghosting.

*edit- OK, it’s not the same problem. Changing vsync (nor any of the other settings) doesn’t seem to help. I’m guessing something’s gone wonky with the occlusion culling?


(Sorelai) #13

Example Screenshots here:


(Svenska) #14

Chiming in here. This is headache inducing.


(Josefine) #15

Was just playing around with it a bit more, and the disappearing building trick can also be triggered by adjusting view distance.

The distance at which things vanish seems quite random. Sometimes increasing it makes closer objects poof, and sometimes decreasing it makes distant objects reappear. This is happening when the camera is stationary while in the menu, so it’s not like the camera frustum is changing.


(Dæmonjesùs) #16

Yeah I had this problem last night, today I turned off all addons, turned down from 7 to 5 , changed to DX11 went from Zandalar to Org and it still happens.

i54690k
RX580 OC 8GB
16 GB RAM…

everything my end is updated and now I can’t log back in.


(Settite) #18

I am having this issue as well. I have tried pretty much every setting combo with and without addons and it still persists. I am using a GTX 980ti. This has pretty much made PTR unplayable for me. I really want to do the raid testing tomorrow but dont think it will be possible if this doesnt get fixed.


(Audrena) #19

Is everyone who’s experiencing this problem using Nvidia cards? And the latest Nvidia drivers, 417.35?


(Settite) #20

Yeah I am using the latest drivers with my 980.


(Snuzzle) #22

Same issue. Makes the game fairly unplayable, needless to say. I do indeed have an Nvdia card.