November Trading Post

Last night, two new swords resembling Sargeras’ sword in Silithis was added to the monthly reward cache for completing the trading post. I completed the trading post on day 2 and did not received the swords in my collection after they were added. When can we expect these to be retroactively added?


In a support thread earlier they said they were working on it but they didnt give a timeline.


Thanks for the update! I looked but didn’t see that thread for some reason

Its on the EU forums :slight_smile:


Seems I’m in the same boat missing the two swords.

Haven’t gotten mine either yet.

I’ve just completed the monthly Traveler’s Log to get the [Arsenal: Cosmic Weapons Cache] and the journal says "You have collected all rewards for this month."There is nothing in my bags (that i can find) and the chest in not interactable.

Not sure what i might have done wrong on my side.

Just now!

Players who didn’t receive the swords due to the bug should now start seeing them, and if you don’t, logging out and back in should do the trick.


Can we also receive the antlers for doing the treasure achievement like everyone else did?


TY GOAT :heart:

Not to be too demanding, but I have one more thing! The Forest Lord’s Antlers were obtainable via the “Treasures of the Emerald Dream” achievement up until a few hours ago. Now, they are attached to the “Dream On” achievement.

I find it to be quite disappointing that this highly sought after transmog was available for two days (and the guy next to me in-game rn has them on), but now players like me have to wait through a month’s worth of timegated quests to receive them. Is there any way we can see this justified?

Thank you Kaivax for updating about the sword as well though! I appreciate the fix and all of your work here on the forums :heart:


Hey, I completed the Treasures of the Emerald Dream achievement and have not gotten the antlers, while others have it right now?

1 Like

Never mind, chest is now lootable. I must have completed it while you folks were in the middle of the fix.

I’ve logged out and back in repeatedly and still haven’t gotten the swords…


You found the missing ones in the chest? So far it isn’t lootable for me (logged out and in 3 times.) Trying to remember who technically finished and did the original loot, just in case.

I just remembered the weapons I got in October and forgot that I’d even need to do anything in November. Thanks for the reminder.

Yeah, I tried this myself. Still not lootable from the chest or purchasable from the vendor. I’m trying to be patient, but all of these little annoyances are piling up fast.


Going to assume the hotfix hasn’t yet been pushed to any Oceanic Servers yet? Have logged in, re-logged in and still none of the appearances.


Tried that, it didn’t work.


Next step: stop making tiny 2H swords for everyone but Gnomes. Thanks. :+1:

1 Like

I still done have it